Bug 896586 - A floating ip can be attached to an instance without allocating that ip
A floating ip can be attached to an instance without allocating that ip
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
2.0 (Folsom)
Unspecified Unspecified
medium Severity high
: snapshot4
: 2.1
Assigned To: Nikola Dipanov
Yaniv Kaul
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-17 10:08 EST by Rami Vaknin
Modified: 2016-04-26 18:29 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-26 11:21:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rami Vaknin 2013-01-17 10:08:29 EST
Version:
Folsom on RHEL6.4
openstack-nova-2012.2.2-5.el6ost.noarch
openstack-nova-network-2012.2.2-5.el6ost.noarch

Scenario:
A floating ip from the floating ips pool (appears in "nova-manage floating list") can be attached to an instance without allocating that ip using "nova floating-ip-create ip_address".

Expected Results:
The ip attachment to the instance should fail.

Example:
[root@puma10 ~(keystone_admin)]$ nova list
+--------------------------------------+------+--------+-------------------------+
| ID                                   | Name | Status | Networks                |
+--------------------------------------+------+--------+-------------------------+
| 482400a0-6286-48ba-b344-c1fbd5b91c6c | rami | ACTIVE | novanetwork=192.168.7.2 |
+--------------------------------------+------+--------+-------------------------+
[root@puma10 ~(keystone_admin)]$ nova floating-ip-list
+-------------+-------------+----------+------+
| Ip          | Instance Id | Fixed Ip | Pool |
+-------------+-------------+----------+------+
| 192.168.8.1 | None        | None     | nova |
+-------------+-------------+----------+------+
[root@puma10 ~(keystone_admin)]$ nova add-floating-ip 482400a0-6286-48ba-b344-c1fbd5b91c6c 192.168.8.10
[root@puma10 ~(keystone_admin)]$ nova floating-ip-list
+-------------+-------------+----------+------+
| Ip          | Instance Id | Fixed Ip | Pool |
+-------------+-------------+----------+------+
| 192.168.8.1 | None        | None     | nova |
+-------------+-------------+----------+------+
[root@puma10 ~(keystone_admin)]$ nova list
+--------------------------------------+------+--------+---------------------------------------+
| ID                                   | Name | Status | Networks                              |
+--------------------------------------+------+--------+---------------------------------------+
| 482400a0-6286-48ba-b344-c1fbd5b91c6c | rami | ACTIVE | novanetwork=192.168.7.2, 192.168.8.10 |
+--------------------------------------+------+--------+---------------------------------------+
[root@puma10 ~(keystone_admin)]$
Comment 3 Russell Bryant 2013-02-12 12:15:11 EST
My gut reaction after reading this is that it is intended behavior.  It's worth looking at a bit closer before closing this, though.
Comment 4 Russell Bryant 2013-02-26 11:21:20 EST
After looking at this again, I still think that this is good behavior and that we should not consider this a bug.  Feel free to reopen if you disagree and would like to discuss further.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.