Bug 896696 - [abrt] claws-mail-3.9.0: crash due to invalid hook on mail_postfiltering_hooklist / newmail plugin related?
Summary: [abrt] claws-mail-3.9.0: crash due to invalid hook on mail_postfiltering_hook...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: claws-mail
Version: 18
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Andreas Bierfert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:2e9649616e16267247d6b1323aa...
: 913553 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-01-17 19:27 UTC by Айфф
Modified: 2014-02-05 22:58 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-05 22:58:04 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (29.38 KB, text/plain)
2013-01-17 19:27 UTC, Айфф
no flags Details
File: cgroup (127 bytes, text/plain)
2013-01-17 19:27 UTC, Айфф
no flags Details
File: core_backtrace (4.20 KB, text/plain)
2013-01-17 19:27 UTC, Айфф
no flags Details
File: dso_list (12.61 KB, text/plain)
2013-01-17 19:28 UTC, Айфф
no flags Details
File: environ (1.46 KB, text/plain)
2013-01-17 19:28 UTC, Айфф
no flags Details
File: limits (1.29 KB, text/plain)
2013-01-17 19:28 UTC, Айфф
no flags Details
File: maps (75.94 KB, text/plain)
2013-01-17 19:28 UTC, Айфф
no flags Details
File: open_fds (899 bytes, text/plain)
2013-01-17 19:28 UTC, Айфф
no flags Details
File: proc_pid_status (920 bytes, text/plain)
2013-01-17 19:28 UTC, Айфф
no flags Details
File: var_log_messages (382 bytes, text/plain)
2013-01-17 19:28 UTC, Айфф
no flags Details

Description Айфф 2013-01-17 19:27:51 UTC
Version-Release number of selected component:
claws-mail-3.9.0-1.fc18

Additional info:
backtrace_rating: 3
cmdline:        /usr/bin/claws-mail
executable:     /usr/bin/claws-mail
kernel:         3.7.2-201.fc18.x86_64
remote_result:  717198
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 ??
 #1 hooks_marshal at hooks.c:108
 #3 g_hook_list_marshal at ghook.c:676
 #4 hooks_invoke at hooks.c:126
 #5 do_copy_msgs at folder.c:3622
 #6 folder_item_move_msgs at folder.c:3675
 #7 inc_start at inc.c:712
 #8 inc_all_account_mail at inc.c:403
 #9 _g_closure_invoke_va at gclosure.c:840
 #11 g_signal_emit_by_name at gsignal.c:3393

Comment 1 Айфф 2013-01-17 19:27:54 UTC
Created attachment 680458 [details]
File: backtrace

Comment 2 Айфф 2013-01-17 19:27:57 UTC
Created attachment 680459 [details]
File: cgroup

Comment 3 Айфф 2013-01-17 19:27:59 UTC
Created attachment 680460 [details]
File: core_backtrace

Comment 4 Айфф 2013-01-17 19:28:02 UTC
Created attachment 680461 [details]
File: dso_list

Comment 5 Айфф 2013-01-17 19:28:04 UTC
Created attachment 680462 [details]
File: environ

Comment 6 Айфф 2013-01-17 19:28:06 UTC
Created attachment 680463 [details]
File: limits

Comment 7 Айфф 2013-01-17 19:28:11 UTC
Created attachment 680464 [details]
File: maps

Comment 8 Айфф 2013-01-17 19:28:34 UTC
Created attachment 680465 [details]
File: open_fds

Comment 9 Айфф 2013-01-17 19:28:37 UTC
Created attachment 680466 [details]
File: proc_pid_status

Comment 10 Айфф 2013-01-17 19:28:39 UTC
Created attachment 680467 [details]
File: var_log_messages

Comment 11 Michael Schwendt 2013-02-28 08:50:21 UTC
How often does it happen? Reproducibly?

Comment 12 Michael Schwendt 2013-02-28 09:32:27 UTC
Another question:

Upstream would like to know whether possibly you had tried and unloaded the NewMail plug-in (claws-mail-plugins-newmail) prior to this crash?

Comment 13 Айфф 2013-02-28 11:26:56 UTC
Проблема возникла один лишь раз и я не знаю, как её воспроизвести. При попытке загрузить NewMail получаю сообщение об ошибке:
"Следующая ошибка произошла при попытке загрузить модуль newmail.so:
No such file or directory".

Comment 14 Michael Schwendt 2013-02-28 12:09:37 UTC
I tried to translate that from Russian to English using Babylon. The error message is much different than in English but it could mean that you've not unloaded the NewMail plugin in the Preferences.

What do you get if you run: grep plugins ~/.claws-mail/clawsrc

Comment 15 Айфф 2013-02-28 15:22:48 UTC
$ grep plugins ~/.claws-mail/clawsrc
pluginswin_width=511
pluginswin_height=300
/usr/lib64/claws-mail/plugins/notification_plugin.so
/usr/lib64/claws-mail/plugins/pgpcore.so
/usr/lib64/claws-mail/plugins/pgpinline.so
/usr/lib64/claws-mail/plugins/pgpmime.so
/usr/lib64/claws-mail/plugins/smime.so
/usr/lib64/claws-mail/plugins/spamreport.so
/usr/lib64/claws-mail/plugins/tnef_parse.so
/usr/lib64/claws-mail/plugins/trayicon.so

Comment 16 Michael Schwendt 2013-02-28 21:05:19 UTC
Okay. So, it's not loaded. Keep your configuration. Don't load the NewMail plugin if you don't need it. Remove the claws-mail-plugins-newmail package if it's installed.

Try to reproduce the crash _without_ using the NewMail plugin. That would be interesting.

Comment 17 Айфф 2013-03-01 11:48:55 UTC
Я не знаю, как воспроизвести эту проблему.

Comment 18 Айфф 2013-03-01 20:09:34 UTC
Это случилось опять, причём я не работал в это время в почтовой программе.

Comment 19 Michael Schwendt 2013-03-02 08:08:11 UTC
Please stop replying in Russian. I do not speak Russian, and all I can do is use online-translation services, but because they are not accurate, we talk past eachother.

So, to sum up:

 - There is only one Claws Mail plug-in, which registers itself on the "mail_postfiltering_hooklist": NewMail
 - If you don't use that plug-in, the "mail_postfiltering_hooklist" list is empty, and no hook would be called when fetching new messages (folder.c line 3622).
 - The attached backtrace is about a crash due to calling an invalid hook.

To me that looks like memory is getting corrupted/damaged somewhere.

Comment 20 Randy Barlow 2013-03-06 19:39:28 UTC
I wrote an e-mail and sent it. The e-mail seemed to make it through SMTP correctly, but it seems that Claws crashed during the step of saving it to my "Sent" IMAP folder.

backtrace_rating: 3
Package: claws-mail-3.9.0-1.fc18
OS Release: Fedora release 18 (Spherical Cow)

Comment 21 Michael Schwendt 2013-03-06 19:55:58 UTC
Randy, avoid the NewMail plugin like a plague for now. I dunno how much you've been playing with it due to the other bug report, but in this case Claws Mail called an invalid mail postfiltering hook. Also see http://www.thewildbeast.co.uk/claws-mail/bugzilla/show_bug.cgi?id=2885

Comment 22 Randy Barlow 2013-03-06 20:17:13 UTC
Understood, I've removed it from my system. Thanks for your help!

Comment 23 Michael Schwendt 2013-03-06 21:59:22 UTC
*** Bug 913553 has been marked as a duplicate of this bug. ***

Comment 24 Fedora End Of Life 2013-12-21 15:18:06 UTC
This message is a reminder that Fedora 18 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 18. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '18'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 18's end of life.

Thank you for reporting this issue and we are sorry that we may not be 
able to fix it before Fedora 18 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior to Fedora 18's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 25 Fedora End Of Life 2014-02-05 22:58:04 UTC
Fedora 18 changed to end-of-life (EOL) status on 2014-01-14. Fedora 18 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.