Bug 89694 - sre.py:137:search:TypeError: expected string or buffer
Summary: sre.py:137:search:TypeError: expected string or buffer
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
(Show other bugs)
Version: 9
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
: 89699 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-26 00:29 UTC by Alex Sanks
Modified: 2007-04-18 16:53 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-19 11:21:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alex Sanks 2003-04-26 00:29:29 UTC
Description of problem:
redhat-config-network always crashes on startup.  The installer never prompted
me to configure my wireless card in my laptop (only the wired, which was not
hooked up).  I manually created a /etc/sysconfig/network-scripts/ifcfg-eth1 and
brought it up.  All worked well.  Running the redhat network configuration,
however, resulted in:

--- BEGIN BACKTRACE OUTPUT ---
Component: redhat-config-network
Version: 1.2.0
Summary: TB
/usr/src/build/228093-i386/install/usr/lib/python2.2/sre.py:137:search:TypeError:
expected string or buffer
Traceback (most recent call last):
  File "/usr/sbin/redhat-config-network-gui", line 154, in ?
    window = mainDialog()
  File
"/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 154, in __init__
  File
"/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 225, in load
  File
"/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 232, in loadDevices
  File
"/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/NCDeviceList.py",
line 210, in getDeviceList
  File
"/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/NCDeviceList.py",
line 117, in load
  File
"/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/plugins/NCDevWireless.py",
line 34, in load
  File
"/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/NCWireless.py",
line 52, in load
  File "/usr/src/build/228093-i386/install/usr/lib/python2.2/sre.py", line 137,
in search
    return _compile(pattern, flags).search(string)
TypeError: expected string or buffer
                                                                               
                                                                               
     
Local variables in innermost frame:
pattern: ^s:
flags: 0
string: None

--- END BACKTRACE OUTPUT ---

Version-Release number of selected component (if applicable):
1.2


How reproducible:
Unable to test, this is my only RH machine.  I tried deleting the ifcfg-eth1 and
the /etc/sysconfig/networking/* directories to no avail.


Relevant Hardware:
Internal 3C59x NIC
MiniPCI Orinoco 802.11b
Dell Inspiron 4100

Comment 1 Harald Hoyer 2003-04-26 13:04:52 UTC
can you please try the bugfix release from:
http://people.redhat.com/harald/redhat-config-network

Comment 2 Harald Hoyer 2003-04-26 13:09:10 UTC
*** Bug 89699 has been marked as a duplicate of this bug. ***

Comment 3 Alex Sanks 2003-04-26 18:37:51 UTC
Thanks for the info, 1.2.3 works fine.


Note You need to log in before you can comment on or make changes to this bug.