Bug 89695 - Mailman fails to start when using service mailman start
Mailman fails to start when using service mailman start
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: mailman (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Dennis
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-25 20:36 EDT by Mike Chambers
Modified: 2007-04-18 12:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-28 10:31:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Chambers 2003-04-25 20:36:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030401

Description of problem:
Upon a fresh install of Shrike, and fresh install of httpd and mailman, when
starting mailman via service mailman start, get traceback errors.

Version-Release number of selected component (if applicable):
mailman-2.1-8

How reproducible:
Always

Steps to Reproduce:
1.Install mailman
2.Install httpd
3.service mailman start
    

Actual Results:  [root@bart root]# service mailman start
Traceback (most recent call last):
  File "/var/mailman/bin/mailmanctl", line 524, in ?
    main()
  File "/var/mailman/bin/mailmanctl", line 319, in main
    check_privs()
  File "/var/mailman/bin/mailmanctl", line 274, in check_privs
    gid = grp.getgrnam(mm_cfg.MAILMAN_GROUP)[2]
KeyError: getgrnam(): name not found


Expected Results:  Mailman should start with no errors

Additional info:

I used to run mailman until a few months ago (no lists to run at the moment). 
But someone else got this error, so thought I would try it out to see what the
problem was.  I don't recall ever having to *start* mailman, as it just worked
after install.
Comment 1 Mike Chambers 2003-04-26 08:03:01 EDT
In /var/mailman/Mailman/mm_cfg.py file, this looks to be the part that is failing..

#    Here's where we override shipped defaults with settings #
#    suitable for the RPM package.                           #
MAILMAN_UID = pwd.getpwnam('mailman')[2]
MAILMAN_GID = grp.getgrnam('mailman')[2]

Someone posted that this is what they did to get that working..

I ran into this problem also. I believe I worked around it by setting 

MAILMAN_USER = 'mailman'
MAILMAN_GROUP = 'mailman'

in my /var/mailman/Mailman/mm_cfg.py file. (There were other values
I needed to customize in this file anyway.) The defaults in
/var/mailman/Mailman/Defaults.py should probably be changed from

MAILMAN_USER = ''
MAILMAN_GROUP = ''

to the values above.

Does this help any?
Comment 2 John Dennis 2003-04-28 10:31:19 EDT
These problems have been fixed in the current rpm, mailman-2.1.1-3
Comment 3 John Dennis 2003-05-01 14:49:04 EDT
*** Bug 90052 has been marked as a duplicate of this bug. ***
Comment 4 John Dennis 2003-09-24 15:18:40 EDT
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-179.html

Note You need to log in before you can comment on or make changes to this bug.