This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 89706 - plot(rand(2,10),rand(2,10)) creates error
plot(rand(2,10),rand(2,10)) creates error
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: octave (Show other bugs)
8.0
i386 Linux
low Severity low
: ---
: ---
Assigned To: Lon Hohberger
http://www.octave.org/mailing-lists/h...
:
: 89707 89708 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-26 07:06 EDT by Niels L Ellegaard
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-28 12:48:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot of plot(rand(2,10),rand(2,10)) w/ 2.1.40 on Red Hat Linux 8.0 (9.33 KB, image/png)
2003-04-28 12:47 EDT, Lon Hohberger
no flags Details

  None (edit)
Description Niels L Ellegaard 2003-04-26 07:06:26 EDT
Description of problem:
When I write plot(rand(2,10),rand(2,10)) I get an eror message

Version-Release number of selected component (if applicable):
GNU Octave, version 2.1.36

How reproducible:
100%

Steps to Reproduce:
Type plot(rand(2,10),rand(2,10)) 
    
Actual results:
parse error:

>>> gplot tmp(:,1:10:11) , tmp(:,2:10:12) , tmp(:,3:10:13) , tmp(:,4:10:14) ,
tmp(:,5
error: evaluating if command near line 42, column 5
error: evaluating if command near line 41, column 3
error: called from `__plt2mm__' in file
`/usr/share/octave/2.1.36/m/plot/__plt2mm__.m'
error: called from `__plt2__' in file `/usr/share/octave/2.1.36/m/plot/__plt2__.m'
error: called from `__plt__' in file `/usr/share/octave/2.1.36/m/plot/__plt__.m'
error: called from `plot' in file `/usr/share/octave/2.1.36/m/plot/plot.m'

Expected results:
A graph should appear

Additional info:
When I write plot(rand(2,3),rand(2,3)), I get the graph that I want.
Comment 1 Lon Hohberger 2003-04-28 11:29:14 EDT
*** Bug 89708 has been marked as a duplicate of this bug. ***
Comment 2 Lon Hohberger 2003-04-28 11:29:23 EDT
*** Bug 89707 has been marked as a duplicate of this bug. ***
Comment 3 Lon Hohberger 2003-04-28 12:46:11 EDT
The above behavior (parse error) indeed occurs on 2.1.36 as shipped with Red Hat
Linux 8.0.  However, it does not occur on 2.1.40-4 as shipped with Red Hat Linux
9.  The Red Hat Linux 9 package is available from:

ftp://ftp.redhat.com/pub/redhat/linux/9/en/os/i386/RedHat/RPMS/octave-2.1.40-4.i386.rpm

and should work on an installed 8.0 system.

Attached is a screenshot of the plot.

Comment 4 Lon Hohberger 2003-04-28 12:47:37 EDT
Created attachment 91340 [details]
Screenshot of plot(rand(2,10),rand(2,10)) w/ 2.1.40 on Red Hat Linux 8.0

Note You need to log in before you can comment on or make changes to this bug.