Bug 89717 - test-4.0.5 + up2date = db4 error(16) from dbenv->remove: Device or resource busy
test-4.0.5 + up2date = db4 error(16) from dbenv->remove: Device or resource busy
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-26 14:31 EDT by Barry K. Nathan
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-21 11:06:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Barry K. Nathan 2003-04-26 14:31:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030313

Description of problem:
When the test-4.0.5 RPMs are installed on Red Hat 7.2 or 7.3, up2date frequently
spews db4 errors. Particularly this one:
error: db4 error(16) from dbenv->remove: Device or resource busy

This happens on:
(a) Red Hat 7.2 with no errata packages other than python-popt (in this case,
the error only appears after all packages have been installed).
(b) Red Hat 7.2 with all errata installed (looks like the example below).
(c) Red Hat 7.3 with all errata installed (this is where the following example
came from).

(I did not test Red Hat 6.0-7.1.)

Rebuilding the RPM database makes no difference. The problem does not happen
when rpm is invoked directly from the command line, instead of through up2date.

Version-Release number of selected component (if applicable):
rpm-4.0.5-1.7x

How reproducible:
Always

Steps to Reproduce:
1. Download the test-4.0.5 RPMs from ftp.rpm.org
2. As root: rpm -Fvh test-4.0.5/*.7x.i386.rpm
3. Use up2date (I tested from the command line, FWIW) to install or update packages.

Actual Results:  [root@localhost root]# up2date -ui

Fetching package list for channel: redhat-linux-i386-7.3...
########################################

Fetching Obsoletes list for channel: redhat-linux-i386-7.3...
########################################

Fetching rpm headers...
########################################
error: db4 error(16) from dbenv->remove: Device or resource busy

Testing package set / solving RPM inter-dependencies...
########################################
LPRng-3.8.9-4.1.i386.rpm:   ########################## Done.                   
libpcap-0.6.2-17.7.3.2.i386 ########################## Done.                   
micq-0.4.10.2-1.i386.rpm:   ########################## Done.                   
Preparing...                ########################################### [100%]

Installing...
   1:LPRng                  ########################################### [100%]
   2:libpcap                ########################################### [100%]
   3:micq                   ########################################### [100%]
error: db4 error(16) from dbenv->remove: Device or resource busy
[root@localhost root]# 

Expected Results:  [root@localhost root]# up2date -ui

Fetching package list for channel: redhat-linux-i386-7.3...
########################################

Fetching Obsoletes list for channel: redhat-linux-i386-7.3...
########################################

Fetching rpm headers...
########################################

Testing package set / solving RPM inter-dependencies...
########################################
LPRng-3.8.9-4.1.i386.rpm:   ########################## Done.                   
libpcap-0.6.2-17.7.3.2.i386 ########################## Done.                   
micq-0.4.10.2-1.i386.rpm:   ########################## Done.                   
Preparing...                ########################################### [100%]

Installing...
   1:LPRng                  ########################################### [100%]
   2:libpcap                ########################################### [100%]
   3:micq                   ########################################### [100%]
[root@localhost root]# 

Additional info:

I'm setting severity to High because the last thing I want to see is RPM
destabilized in a 7.x or RHEL 2.1 errata. If that's an overreaction (e.g.,
because the bug happens to be harmless or something) let me know, or just go
ahead and lower the severity.
Comment 1 Roger Koot 2003-05-01 11:48:21 EDT
this error is also triggered when doing 'rpm --rebuilddb' on a redhatbox
upgraded from redhat 7.1 to redhat 9.
rpm queries, source-rpm rebuilds, installations and deinstallations work as
expected; only 'rpm --rebuilddb' triggers the 'db4 error(16) from dbenv->remove:
Device or resource busy'
Comment 2 Barry K. Nathan 2003-05-01 15:25:38 EDT
Roger, that's a different bug (to the best of my knowledge). That one has been
discussed to death repeatedly, elsewhere in Red Hat Bugzilla (I don't remember
the exact bug numbers, and even if I did, I don't know which one would be best).
In your case, the error causes no harm and you should just ignore it.

This one happens with up2date, *not* rpm --rebuilddb, and it happens with RPM
test-4.0.5, *not* any 4.1.x or 4.2 version.
Comment 3 Jeff Johnson 2003-08-21 11:06:16 EDT
Fixed in rpm-4.2.1 a couple of weeks ago.

Note You need to log in before you can comment on or make changes to this bug.