Bug 89723 - Installation from CD writer sets up /dev/cdrom incorrectly?
Installation from CD writer sets up /dev/cdrom incorrectly?
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
9
i686 Linux
high Severity high
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-26 17:47 EDT by Peter Baitz
Modified: 2014-03-16 22:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-27 17:38:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Baitz 2003-04-26 17:47:40 EDT
Description of problem:
cannot mount cdrom on new install of Red Hat Linux 9.0

Version-Release number of selected component (if applicable):
Red Hat Linux 9.0 (kernel 2.4.20-8 scratch install) and
Red Hat Linux 9.0 (kernel 2.4.20-9 and all errata updates)

How reproducible:
Every time.  

Steps to Reproduce:
1. insert cdrom
2. type the mount command
3. get error shown above
    
Actual results:
[root@boaz rpm]# mount /dev/cdrom /mnt/cdrom -t iso9660
mount: wrong fs type, bad option, bad superblock on /dev/cdrom,
       or too many mounted file systems
       (could this be the IDE device where you in fact use
       ide-scsi so that sr0 or sda or so is needed?)
[root@boaz rpm]#

[root@boaz rpm]# mount /mnt/cdrom
mount: wrong fs type, bad option, bad superblock on /dev/cdrom,
       or too many mounted file systems
       (could this be the IDE device where you in fact use
       ide-scsi so that sr0 or sda or so is needed?)
[root@boaz rpm]#


Expected results:
should have /mnt/cdrom mounted.


Additional info:
[root@boaz rpm]# lsmod
Module                  Size  Used by    Tainted: PF
videodev                8544   0
es1371                 34920   2  (autoclean)
gameport                3508   0  (autoclean) [es1371]
ac97_codec             13768   0  (autoclean) [es1371]
soundcore               7044   4  (autoclean) [es1371]
vmnet                  24552   4
vmmon                  29844   0  (unused)
parport_pc             19204   1  (autoclean)
lp                      9188   0  (autoclean)
parport                39072   1  (autoclean) [parport_pc lp]
iptable_filter          2412   0  (autoclean) (unused)
ip_tables              15864   1  [iptable_filter]
autofs                 13684   0  (autoclean) (unused)
ne2k-pci                7232   1
8390                    9056   0  [ne2k-pci]
microcode               5184   0  (autoclean)
ide-scsi               12432   0
ide-cd                 35772   0
cdrom                  34176   0  [ide-cd]
st                     31920   0  (unused)
keybdev                 2976   0  (unused)
mousedev                5656   1
hid                    22308   0  (unused)
input                   6208   0  [keybdev mousedev hid]
usb-uhci               27404   0  (unused)
usbcore                82592   1  [hid usb-uhci]
ext3                   73376   3
jbd                    56336   3  [ext3]
aic7xxx               142516   0  (unused)
sd_mod                 13452   0  (unused)
scsi_mod              110488   4  [ide-scsi st aic7xxx sd_mod]
[root@boaz rpm]#

[root@boaz rpm]# cat /etc/fstab
LABEL=/                 /                       ext3    defaults        1 1
LABEL=/boot             /boot                   ext3    defaults        1 2
LABEL=/data             /data                   ext3    defaults        0 0
none                    /dev/pts                devpts  gid=5,mode=620  0 0
none                    /proc                   proc    defaults        0 0
none                    /proc/bus/usb           usbdevfs noauto         0 0
none                    /dev/shm                tmpfs   defaults        0 0
/dev/hde6               swap                    swap    defaults        0 0
#/dev/cdrom             /mnt/cdrom              udf,iso9660
noauto,owner,kudzu,ro 0 0
/dev/cdrom              /mnt/cdrom              iso9660 noauto,owner,kudzu,ro 0 0
/dev/fd0                /mnt/floppy             auto    noauto,owner,kudzu 0 0
Comment 1 Peter Baitz 2003-04-26 17:50:37 EDT
#grub.conf

#boot=/dev/hde
default=0
timeout=10
splashimage=(hd0,0)/grub/splash.xpm.gz
title Red Hat Linux-smp (2.4.20-9smp)
        root (hd0,0)
        kernel /vmlinuz-2.4.20-9smp ro root=LABEL=/ hda=ide-scsi
        initrd /initrd-2.4.20-9smp.img
title Red Hat Linux-up (2.4.20-9)
        root (hd0,0)
        kernel /vmlinuz-2.4.20-9 ro root=LABEL=/ hda=ide-scsi
        initrd /initrd-2.4.20-9.img
Comment 2 Peter Baitz 2003-04-26 17:51:59 EDT
#Device cdrom in /dev

[root@boaz dev]# ls -l cdrom
lrwxrwxrwx    1 root     root            8 Apr 20 23:12 cdrom -> /dev/hda
[root@boaz dev]# ls -l hda
brw-------    1 root      disk       3,   0 Jan 30 05:24 hda
Comment 3 Peter Baitz 2003-04-26 17:54:56 EDT
This same PC has Red Hat Linux 7.3 on it prior to this. I backed up my home
directory and files, so when I installed 9.0 I HAD INSTALL FORMAT THE DISKS CLEAN.

Point of telling you this is under 7.3 I HAD NO CDROM PROBLEMS so I know the
hardware is fine!  ;-)
Comment 4 Peter Baitz 2003-04-26 19:19:07 EDT
UPDATE!  in Gnome I went into Start Here / System Tools / X CDroast Cd Writer
and stepped through its configuration.  Once I did that, the CDROM mounted
perfectly.
Now it seems to mount fine from command line or from the Disk Manager tool, for
now anyway....  What happened to fix it??????????????
Comment 5 Peter Baitz 2003-04-26 19:25:35 EDT
I noted this "lsmod" change after doing the xcdroast setup:

Before:
scsi_mod              110488   4  [ide-scsi st aic7xxx sd_mod]

After:
scsi_mod        110488   6  [sg sr_mod ide-scsi st aic7xxx sd_mod]
                             ^^ ^^^^^^

Weird thing is I'm sure I tried this manually after comparing to my 9.0 install
at work, but it made no diff.  xcdroast did something to fix it. 
Comment 6 Peter Baitz 2003-04-26 20:42:48 EDT
Spoke too soon - after REBOOTING Linux, it was back to same error on mounting
the CDROM. Still need help fixing this issue.
Comment 7 Peter Baitz 2003-04-26 21:04:51 EDT
Found out from checking in CD-Writer (a Gnome Utility) that my CDROM is /dev/scd0
not /dev/hda !

When I specify mount /dev/scd0 /mnt/cdrom -t iso9660 then is mounts fine!

So the question is why did the Linux installer chose to use /dev/hda 
as my CDROM such as in the grub.conf ???  




Comment 8 Harald Hoyer 2003-04-27 09:11:05 EDT
this is more a bug of the installer (anaconda).. I am reassigning..
Comment 9 Michael Fulbright 2003-04-28 14:55:26 EDT
Did you install from CD, and if so, which device did you install from?
Comment 10 Peter Baitz 2003-04-28 17:23:30 EDT
I installed from the same CD device as the one I have trouble mounting.
Specifically it should be /dev/hda  but  I can only mount it as /dev/scd0

It is a CD-Read/Write device. I only have this one CD device in my PC. 

Yes I installed completely from a 3-CD set.
Comment 11 Michael Fulbright 2003-04-30 14:58:44 EDT
I'll assign this to be looked at. The reason the device is /dev/scd0 after you
reboot is that ATAPI CD burners look like a SCSI device to the kernel.  If you
want a quick workaround you will want to move the symlink for /dev/cdrom to
point at /dev/scd0.
Comment 12 Peter Baitz 2003-05-01 09:44:24 EDT
Michael thank you for the workaround suggestion, however I did in fact try that
already (changed the symlink /dev/cdrom --> /dev/scd0 rather than /dev/hda, and
yes mounting /mnt/cdrom worked fine then) but for some odd reason, after I
rebooted, the system had *automagically* changed that symlink /dev/cdrom to
point back at /dev/hda !   ?:-(   

Comment 13 Bill Nottingham 2003-06-26 10:48:27 EDT
What does your ide setup look like in general (which devices are what drives, etc.)?
Comment 14 Bill Nottingham 2004-09-27 17:38:59 EDT
Closing, lack of response.

Note You need to log in before you can comment on or make changes to this bug.