Bug 89749 - netmask was calculate automatically
netmask was calculate automatically
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-27 13:11 EDT by acount closed by user
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-30 00:07:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description acount closed by user 2003-04-27 13:11:44 EDT
Description of problem:

with old rh installation console program, netmasks was calcutate automatically.
can you integrate the code ?

-thanks-

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:
Comment 1 Michael Fulbright 2003-04-28 16:27:03 EDT
Do you have a particular autocalculation in mind?
Comment 2 acount closed by user 2003-04-29 15:25:16 EDT
I can remember that _netconfig_ has this feature when you type the IP and then
press <tab> key. And IMHO a lot of people know what it is a IP but they don't
have enough knowledge about TCP/IP subneting... and this is a trouble at
installing time
And because some times I am lazy ;-)

-thank you-
Comment 3 Jeremy Katz 2003-04-30 00:07:59 EDT
The "calculation" was just using classes and these days, CIDR is more common
than following just a stock A, B, or C class network.  So the calculation was
wrong more times than not and thus it makes more sense to just default to
255.255.255.0 always for consistency and because it's right more often.

Note You need to log in before you can comment on or make changes to this bug.