Bug 89768 - Option "DDCmode" "false" crashes radeon Xserver
Summary: Option "DDCmode" "false" crashes radeon Xserver
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
(Show other bugs)
Version: 9
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-28 02:41 UTC by D. Hugh Redelmeier
Modified: 2007-04-18 16:53 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-14 09:45:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XF86Config that provokes server crash (3.97 KB, text/plain)
2003-04-28 02:45 UTC, D. Hugh Redelmeier
no flags Details
/var/log/XFree86.0.log recording crash (45.00 KB, text/plain)
2003-04-28 02:46 UTC, D. Hugh Redelmeier
no flags Details

Description D. Hugh Redelmeier 2003-04-28 02:41:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
I'm having a lot of problems with my setup (Radeon 9000, two monitors, RHL9). 
In desperation, I added
    Option  "DDCmode" "false"
to one of the Monitor sections.  This caused X to segfault.

I put this option right after
    Option      "dpms"
This latter option was processed just before the segfault

Version-Release number of selected component (if applicable):
XFree86-4.3.0-2

How reproducible:
Always

Steps to Reproduce:
1.put the option in XF86Config
2.startx
3.boom
    

Actual Results:  (**) Option "dpms"
(**) RADEON(0): DPMS enabled
(II) RADEON(0): Direct rendering disabled
(==) RandR enabled

   *** If unresolved symbols were reported above, they might not
   *** be the reason for the server aborting.

Fatal server error:
Caught signal 11.  Server aborting


Additional info:

I will attach my XF86Config and /var/log/XFree86.0.log

Comment 1 D. Hugh Redelmeier 2003-04-28 02:45:10 UTC
Created attachment 91324 [details]
XF86Config that provokes server crash

Comment 2 D. Hugh Redelmeier 2003-04-28 02:46:20 UTC
Created attachment 91325 [details]
/var/log/XFree86.0.log recording crash

Comment 3 D. Hugh Redelmeier 2003-04-28 03:33:20 UTC
hmm.  Something else is going on: I have been able to use the option without X
crashing.  Will report when I figure out more.


Comment 4 Mike A. Harris 2003-04-28 08:49:37 UTC
Video driver options go in the video driver "Device" section of the config
file, not in the Monitor or ServerFlags sections.

Comment 5 Mike A. Harris 2003-04-28 08:51:28 UTC
XFree86-Servers doesn't exist in Red Hat Linux 8.0 or 9, reassigning to
XFree86.

Comment 6 D. Hugh Redelmeier 2003-04-29 03:16:00 UTC
Thanks Mike.  Moving the option eliminates the crash.
Still, crashing is a bug, I'd say.

Comment 7 Mike A. Harris 2003-05-14 09:45:09 UTC
An X server crashing due to being misconfigured might be a bug, but it is
an extremely low priority bug which isn't worth engineering time to investigate
and fix, when there are hundreds of bugs open which actually prevent users from
using X, or are much more serious.

Please file this bug report upstream at http://bugs.xfree86.org for the
community of X developers to fix it.

Our official workaround for this problem is to not misconfigure your X server
in a bogus manner, and it will work properly.


Note You need to log in before you can comment on or make changes to this bug.