Bug 89860 - undefined symbol: XRenderCreateAnimCursor
undefined symbol: XRenderCreateAnimCursor
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-28 19:21 EDT by John Williams
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-29 18:01:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Williams 2003-04-28 19:21:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686) Gecko/20030313 Galeon/1.3.4

Description of problem:
Many X applications (for example RedHat config tools, Ximian Red Carpet)   fail
to display with the following error message:

/usr/X11R6/lib/libXcursor.so.1: undefined symbol: XRenderCreateAnimCursor

For example:

[root@localhost jwilliams]# redhat-config-printer-gui
/usr/bin/python: relocation error: /usr/X11R6/lib/libXcursor.so.1: undefined
symbol: XRenderCreateAnimCursor


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. run redhat-config-printer-gui from terminal
2.
3.
    

Actual Results:  /usr/bin/python: relocation error:
/usr/X11R6/lib/libXcursor.so.1: undefined symbol: XRenderCreateAnimCursor

Expected Results:  application should have displayed

Additional info:
Comment 1 Mike A. Harris 2003-04-29 14:52:54 EDT
This seems to be due to many of the libraries that are part of XFree86 not
being linked to their dependant libs at build time.  This forces application
authors to manually link to all of those dependant libs, which is very broken.

It's odd that these problems have never turned up before, because _many_
libraries have this same problem.  I fixed a similar problem in libXfont
a couple weeks ago, but I've now fixed a whackload of them including
libXcursor.  Not sure if I caught them all yet or not though.

I'll update the report when new packages are available to test.

Thanks.
Comment 2 Mike A. Harris 2003-04-29 23:42:39 EDT
Are you using prelink?
Comment 3 John Williams 2003-04-30 03:39:40 EDT
I wasn't, but I have since installed it and the problem persists:

[root@localhost jwilliams]# rpm -ihv Data/RPMS/RedHat/prelink-0.2.0-18.i386.rpm
                                                                                
Preparing...                ########################################### [100%]
   1:prelink                ########################################### [100%]
 
 
[root@localhost jwilliams]# up2date
/usr/bin/python: relocation error: /usr/X11R6/lib/libXcursor.so.1: undefined
symbol: XRenderCreateAnimCursor
[root@localhost jwilliams]#

Comment 4 Mike A. Harris 2003-04-30 21:38:27 EDT
Actually, my question was upon an assumption that prelinking might be
part of the problem being visible all of a sudden to people.  I wasn't
suggesting that you install or use prelink.  ;o)



Comment 5 Mike A. Harris 2004-09-29 18:01:38 EDT
We are unable to reproduce this problem on Red Hat Linux 9,
Fedora Core 1, or Fedora Core 2.

Setting status to "WORKSFORME".  If the problem recurs with
Fedora Core 2, please reopen and provide a status update.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.