Bug 89864 - make bzImage crashes when trying to compile NTFS driver
make bzImage crashes when trying to compile NTFS driver
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
9
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
: 89983 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-28 21:50 EDT by derek slayton
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-07 06:32:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description derek slayton 2003-04-28 21:50:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
when trying to compile the 2.1 ntfs driver from sourceforge.net (specifically
running the make bzImage command) i get this error:

ASENAME=blkpg  -DEXPORT_SYMTAB -c blkpg.c
gcc -D__KERNEL__ -I/usr/src/linux-2.4.20-9/include -Wall -Wstrict-prototypes
-Wno-trigraphs -O2 -fno-strict-aliasing -fno-common -fomit-frame-pointer -pipe
-mpreferred-stack-boundary=2 -march=i586   -nostdinc -iwithprefix include
-DKBUILD_BASENAME=genhd  -DEXPORT_SYMTAB -c genhd.c
genhd.c: In function `part_show':
genhd.c:221: internal error: Illegal instruction
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[3]: *** [genhd.o] Error 1
make[3]: Leaving directory `/usr/src/linux-2.4.20-9/drivers/block'
make[2]: *** [first_rule] Error 2
make[2]: Leaving directory `/usr/src/linux-2.4.20-9/drivers/block'
make[1]: *** [_subdir_block] Error 2
make[1]: Leaving directory `/usr/src/linux-2.4.20-9/drivers'
make: *** [_dir_drivers] Error 2


Version-Release number of selected component (if applicable):
kernel-2.4.20-9

How reproducible:
Always

Steps to Reproduce:
1. patch kernel with ntfs driver
2. run makexconfig select ntfs driver to be installed
3. run make bzImage
    

Actual Results:  ASENAME=blkpg  -DEXPORT_SYMTAB -c blkpg.c
gcc -D__KERNEL__ -I/usr/src/linux-2.4.20-9/include -Wall -Wstrict-prototypes
-Wno-trigraphs -O2 -fno-strict-aliasing -fno-common -fomit-frame-pointer -pipe
-mpreferred-stack-boundary=2 -march=i586   -nostdinc -iwithprefix include
-DKBUILD_BASENAME=genhd  -DEXPORT_SYMTAB -c genhd.c
genhd.c: In function `part_show':
genhd.c:221: internal error: Illegal instruction
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[3]: *** [genhd.o] Error 1
make[3]: Leaving directory `/usr/src/linux-2.4.20-9/drivers/block'
make[2]: *** [first_rule] Error 2
make[2]: Leaving directory `/usr/src/linux-2.4.20-9/drivers/block'
make[1]: *** [_subdir_block] Error 2
make[1]: Leaving directory `/usr/src/linux-2.4.20-9/drivers'
make: *** [_dir_drivers] Error 2


Expected Results:  bzImage compile should have completed

Additional info:
Comment 1 Jakub Jelinek 2004-10-07 06:32:46 EDT
It is not make that crashed, but gcc.  And the most probable reason
is flakey hardware.
Others can build the kernel just fine and GCC bugs would show as
aborts resp. in rare cases segfaults, but not illegal instruction
failures.
Comment 2 Jakub Jelinek 2004-10-07 06:34:14 EDT
*** Bug 89983 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.