Bug 8989 - Finally SOLVED (for me at least)!! Windows 95/98/98 SE slow with SAMBA and/or FTP.
Finally SOLVED (for me at least)!! Windows 95/98/98 SE slow with SAMBA and/o...
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: samba (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-30 14:25 EST by Edmund Chan III
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-01 17:36:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edmund Chan III 2000-01-30 14:25:32 EST
I had a problem (I thought) with  FTP and SAMBA being slow, I looked for
solutions with this and found nothing but other people with the same
problem and no answer..

I had 3 systems.  1-Win 98, 1-Win 98 SE, 1-RedHat Linux 6.0 running
SAMBA.  The SAMBA Server is a 350 MHz AMD K6 II w/UDMA66 EIDE HD's.  Here
is what was happening:

Using a test file of 167MB's, and either FTP or Copying with Explorer,
copying to and from each Windows box, I got the following results:

Copying at the Win 98 Box
------------------------------------------
COPY To Win98 SE =  3 mins
COPY From Win98 SE =  3 mins
COPY To SAMBA Server =  3 mins
COPY From SAMBA Server = 43 mins (If it ever finishes)

Copying at the Win 98 SE Box
----------------------------------------------
COPY To Win98  =  3 mins
COPY From Win98  =  3 mins
COPY To SAMBA Server =  3 mins
COPY From SAMBA Server = 3 mins

Never tried reading or writing FROM the console of the SAMBA Server.

Well, I solved my problem!  Maybe it's the same for others and I mean it's
an INCREDIBLE difference in performance on the Win 98 Box!!

Make a long story short, after realizing just how bad the performance was
I decided to try "one of those" internet access speed up utilities that
just about everyone has at least tried.  They adjust the MTU's and a bunch
of other stuff..  In all actuallity, it was probably one of the caching
speedup utilities that caused this problem long ago...

Well guess what..!  I tried a utility that I found on TUCOWS.COM.  It's
called Accelerate 2000 and it worked.. I set it for Network/Lan Support
and told it to adjust automatically and the results are astounding!  Below
are the results..

Using a test file of 167MB's, copying to and from from each Windows box,
I get the following results:

Copying at the Win 98 Box
------------------------------------------
COPY To Win98 SE =  3 mins
COPY From Win98 SE =  3 mins
COPY To SAMBA Server =  30 secs
COPY From SAMBA Server = 30 secs
(That's right!  Stunning improvement!!)

Copying at the Win 98 SE Box
----------------------------------------------
COPY To Win98  =  3 mins
COPY From Win98  =  3 mins
COPY To SAMBA Server =  3 mins
COPY From SAMBA Server = 3 mins

I think the reason that the Win 98 SE box is so slow is because it's a
laptop with a D-Link PC card that is only half duplex on a 100 Mb
network.  I need to get a 3COM PC Card so I can have full duplex on the 100
Mb and an XJack connector!

The results are so astounding, that I then burned that 167 MB ISO file
FROM the SAMBA server to a 12x CD Recorder on the Win 98 box in around 5
minutes with NO "Buffer underruns"!  That's a lot faster than a local file
would have taken to burn!

Since I came across this solution, I have told 5 others that were
complaining in news groups about SAMBA being slow.  Well, ALL of them are
blown away after setting things right and this worked for all of them.

Anyway..  I didn't know how else to report this, but maybe it should be in
an FAQ or something..  I always see people complaining because they think
it is a SAMBA thing because that is where they notice it first!

Hey.. Also, just wanted to say.. KEEP UP THE GOOD WORK !!

C'ya,
Edmund
edmund@wildworld.net
Comment 1 Bill Nottingham 2000-02-01 17:36:59 EST
Hmm... seems like there's some sort of bug in the Win98 TCP/IP stack.
Good to know, though.

Note You need to log in before you can comment on or make changes to this bug.