Bug 89899 - crontab: no changes made to crontab
Summary: crontab: no changes made to crontab
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: vixie-cron (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jason Vas Dias
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-29 15:36 UTC by Liberty RMS - Sysadmins
Modified: 2007-04-18 16:53 UTC (History)
0 users

Fixed In Version: vixie-cron-4.1-8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-10 19:22:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Liberty RMS - Sysadmins 2003-04-29 15:36:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020913

Description of problem:
Reads like bug 60338 which is closed as a duplicate of 37771 which is also closed.

60338 is a bug against vixie cron, 37771 is against vi

When /tmp is a link changes made via crontab -e are not saved, when /tmp is a
real directory the changes are saved.

Version-Release number of selected component (if applicable):
vixie-cron-3.0.1-64, vim-common-6.1-18.7x.2, vim-enhanced-6.1-18.7x.2,
vim-minimal-6.1-18.7x.2

How reproducible:
Always

Steps to Reproduce:
1.make /tmp a soft link to some other location
2.
3.
    

Actual Results:  Run the command crontab -e on an existing crontab and maker
changes via the editor (vim) and exit (:wq) receive the line 
crontab: no changes made to crontab

Expected Results:  Run the command crontab -e on an existing crontab and maker
changes via the editor (vim) and exit (:wq) receive the line 
crontab: installing new crontab
 
Additional info:  A which of vi return the following information 
alias vi='vim'
	/usr/bin/vim

Comment 1 Roger Nunn 2004-05-13 10:50:46 UTC
This symptom also occurs when EDITOR=vi -n which should ignore the
vimrc file.

 


Note You need to log in before you can comment on or make changes to this bug.