Bug 89937 - crontab hangs on invalid input
crontab hangs on invalid input
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: vixie-cron (Show other bugs)
8.0
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Brock Organ
:
: 114386 (view as bug list)
Depends On:
Blocks: 170808
  Show dependency treegraph
 
Reported: 2003-04-29 19:55 EDT by Trenton Lipscomb
Modified: 2007-04-18 12:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-30 19:07:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Trenton Lipscomb 2003-04-29 19:55:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312

Description of problem:
When entering an illegal crontab, crontab hangs and consumes 100% of cpu time.
Yes, you could say this is user error, but the error recovery of crontab should
be improved.

Version-Release number of selected component (if applicable):
vixie-cron-3.0.1-69

How reproducible:
Always

Steps to Reproduce:
1. Call crontab -e on the command line.
2. Add a line which reads:

*/__WONKY__ * * * * /bin/true

3. Save and exit the editor.

Actual Results:  The editor never exits, crontab consumes 100% of cpu time.

Expected Results:  An error should be returned. Something like:

crontab: installing new crontab
"/tmp/crontab.16807":1: bad minute
errors in crontab file, can't install.
Do you want to retry the same edit?


Additional info:
Comment 1 Trenton Lipscomb 2004-04-05 16:30:20 EDT
Reassigning to queue owner. Not sure how it got assigned to me...
Comment 2 Jens Petersen 2004-06-30 12:40:03 EDT
*** Bug 114386 has been marked as a duplicate of this bug. ***
Comment 3 Jens Petersen 2004-06-30 12:41:37 EDT
Should get fixed in 3.0.1-94.
Comment 4 Jason Vas Dias 2004-08-30 19:06:24 EDT
This was fixed in 3.0.1-94 & in current version : vixie-cron-4.1-10. 

Note You need to log in before you can comment on or make changes to this bug.