Bug 89940 - bind/named does not start despite addendum fix and notes from RH
bind/named does not start despite addendum fix and notes from RH
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: bind (Show other bugs)
9
All Linux
high Severity high
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-29 22:02 EDT by Mark
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version: bind-9.2.2-13.i386.rpm
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-30 18:24:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark 2003-04-29 22:02:01 EDT
Description of problem:  Bind (named daemon) does not start despite the 
addendum fix attached with software. I emphasized high under priority and 
severity due to the fact that MX records cannot be checked on process/email 
forms thus, allowing any user to input invalid email addresses.


Version-Release number of selected component (if applicable): RH 9.0


How reproducible:


Steps to Reproduce:
1.Install RPM bind from the installation cd during install.  (Also attempted 
to uninstall after install and reinstall but bind rpm could not be found yet 
wouldn't allow reinstall of itself.)
2. flushed iptables iptables -F, stopped iptables, and vice versa. 
3. Then attempted to restart named w/out any luck and attempted to uninstall 
named to reinstall named and any associated files/rpms necessary to 
successfully do so with same error as indicated above on number 1 (rpm could 
not be found.)
4. This named issue has occurred on two different platforms (1. PII, Intel 
Mboard, 2. AMD cpu, Asus mboard) with same disappointing results
    
Actual results:Named simply does not start and the systems indicate bind/named 
is installed but does not find bind when attempting to uninstall.


Expected results: Named should start at bootup or upon chkconfig --level 345 
named.  


Additional info:  none
Comment 1 Daniel Walsh 2003-04-30 07:11:07 EDT
What are you seeing in /var/log/messages?  Do you see bind if you do a 
rpm -q -a | grep bind?  

Dan
Comment 2 Mark 2003-04-30 11:36:31 EDT
The results of the command were as follows.

redhat-config-bind-1.9.0-13
bind-9.2.1-16
bind-utils-9.2.1-16
ypbind-1.11-4
bind-devel-9.2.1-16
#end

Yet, uninstalling can't find them, and resinstalling indicates their already
installed?
Comment 3 Daniel Walsh 2003-04-30 11:48:29 EDT
To uninstall them are you using 

rpm -e bind
rpm -e redhat-config-bind
Comment 4 Mark 2003-04-30 13:32:28 EDT
Yes, -e is being used.  Unfortunately, --force can't be used or else I would.  
Upon using option: -e, this is when I receive the infamous "Cannot find the 
bind related utilities and bind itself." error messages.  If I choose to 
reinstall them, I receive: "Already installed"   It's 'currently' a no win 
situation.

Thanks,
Mark
Comment 5 Daniel Walsh 2003-04-30 13:51:20 EDT
Are you able to remove any packages?  It seems to me that your RPM database is
screwed up.

You could attempt and rpm --rebuilddb.

You never answered my original question about what is reported when you start
the named in /var/log/messages.

Dan
Comment 6 Mark 2003-04-30 14:10:34 EDT
Here's a log message dated 4/26 pertaining to named.  This is all that was 
reported in regards to named.  However, I can send you the entire log file, 
but it can't be done here due to no attachment option.  Let me know.
In addition, I'll give the db rebuild a whirl, test it, and let you know the 
outcome. 

Apr 26 07:55:57 isprofessionals named[1843]: app.c:561: unexpected error:
Apr 26 07:55:57 isprofessionals named[1843]: isc_app_shutdown() pthread_kill: 
No such process


Mark
Comment 7 Mark 2003-04-30 14:26:49 EDT
Upon rebuilding rpm db (rpm --rebuilddb), the following message appeared:

error: db4 error(16) from dbenv->remove: Device or resource busy


Named did not appear to start after attempting to restart named.
Comment 8 Daniel Walsh 2003-04-30 14:50:38 EDT
The message that is in the log file is caused by a kernel problem that has an
errata.  This happens when you stop the named service, which means that named
started one time.  Have you checked to see if a named process is running?  
It may be in a zombie start.  Do a killall named to stop it and then a 
service named start to start it up.  I believe you can get the fixed kernel
through rhn.

Dan
Comment 9 Mark 2003-04-30 16:07:49 EDT
Killed named and started it up again with the same old results.  Also, The 
kernel was updated (on both platforms), even rebooted, then tested by applying 
the killall and start of named again with the same old results.  Don't know 
what else to do as it is occurring on two different platforms.  Can however, 
send any other files that may be helpful via an e-mail to Ben and Daniel along 
with myself.  At startup, the named daemon displays itself for a split second 
and then disappears while the other daemons continue to display their startups.

Mark
Comment 10 Daniel Walsh 2003-04-30 16:16:06 EDT
You are receiving nothing in the log file indicating that named is dying?
Could you update to the latest bind on rawhide bind-9.2.2-*.  This version
handles some threads race conditions better, although I haven't heard of your
problem till now.

Dan
Comment 11 Mark 2003-04-30 16:41:00 EDT
The following error messages occur when trying to upgrade the rawhide verions of
bind-9.2.2-13.i386.rpm

libdns.so.8 is needed by bind-9.2.2-13
bind = 9.2.1 is needed by (installed) bind-devel-9.2.1-16

As the previous notes stated: bind is installed when attempting to reinstall
according to the rpm install attempt
Or, bind is not installed when attempting to uninstall according to rpm -e 

How can I force the uninstall of bind and all of its related values and files in
order to attempt the reinstall?

One more note:  the install and uninstall has also been attempted via the GUI
package manager Add/Remove Apps with the same confused results.

Mark
Comment 12 Mark 2003-04-30 16:46:17 EDT
Killed named and started it up again with the same old results.  Also, The 
kernel was updated (on both platforms), even rebooted, then tested by applying 
the killall and start of named again with the same old results.  Don't know 
what else to do as it is occurring on two different platforms.  Can however, 
send any other files that may be helpful via an e-mail to Ben and Daniel along 
with myself.  At startup, the named daemon displays itself for a split second 
and then disappears while the other daemons continue to display their startups.

Mark
Comment 13 Mark 2003-04-30 16:49:42 EDT
------- Additional Comment #11 From Mark on 2003-04-30 16:41 -------  

The following error messages occur when trying to upgrade the rawhide verions 
of
bind-9.2.2-13.i386.rpm

libdns.so.8 is needed by bind-9.2.2-13
bind = 9.2.1 is needed by (installed) bind-devel-9.2.1-16

As the previous notes stated: bind is installed when attempting to reinstall
according to the rpm install attempt
Or, bind is not installed when attempting to uninstall according to rpm -e 

How can I force the uninstall of bind and all of its related values and files 
in order to attempt the reinstall?

One more note:  the install and uninstall has also been attempted via the GUI
package manager Add/Remove Apps with the same confused results.

Mark
 
Comment 14 Daniel Walsh 2003-04-30 16:51:54 EDT
Sorry you need to grab all the bind*9.2.2-13 off of rawhide and upgrade them
simultaneously 

rpm -Uhv bind*
Comment 15 Mark 2003-04-30 18:24:37 EDT
Gents,
  The rawhide betas seemed to have resolved the named startup issue and is 
once again allowing our contact page to perform MX record checks again.  Buy 
you a cold one the next time you're in Seattle.

Mark

Note You need to log in before you can comment on or make changes to this bug.