Bug 89947 - redhat-config-httpd saves errors in httpd.conf file
redhat-config-httpd saves errors in httpd.conf file
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-httpd (Show other bugs)
9
i586 Linux
medium Severity low
: ---
: ---
Assigned To: Phil Knirsch
:
: 97081 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-30 02:23 EDT by Eric B
Modified: 2015-03-04 20:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-01 11:21:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric B 2003-04-30 02:23:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
When configuring the web server as a virtual host server, redhat-config-httpd
saves incorrect information in various places within the file.

1) There is no NameVirtualHost directive
2) There is no place to specify values for NameVirtualHost directive
3) Duplicate entries are set for TransferLog when specified
4) In directory options, the word 'from' appears twice.
   eg. 'Allow from from all'
5) The 'Directory Page Search List' is not transferred to the DirectoryIndex
directive.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. In KDE select Menu->System_Settings->Server-Settings->HTTP_Server
2. Select 'Virtual Host' Tab
3. Select 'Add' to add a virtual host
4. Select 'Name based Virtual host'
5. Complete fields Virtual_Host_Name, Document_root, Webmaster_Email,
IP_Address, Server_Host_Name with valid information.
6. Select 'Site_Configuration' from list on left.
7. Add index.html to 'Directory Page Search List'
6. Select OK
7. Select OK
8. Select Yes to save and exit.
9. View errors in /etc/httpd/conf/httpd.conf file
    

Actual Results:  1) There is no NameVirtualHost entry
2) Duplicate entries are set for TransferLog when specified
3) In directory options, the word 'from' appears twice.
4) The 'Directory Page Search List' values are not transferred to the
DirectoryIndex directive.

Expected Results:  A valid NameVirtualHost line should specify the IP address of
the server.
There should not be duplicate entries for TransferLog.
Directory options should be correct.


Additional info:

This bug can be worked around by editing the httpd.conf file manually.
May be more serious for persons who are not familliar with httpd.conf files.
I give this a PIA factor of 3.
Comment 1 Eric B 2003-05-08 02:25:23 EDT
Updates to initial bug report.
1) There is no NameVirtualHost directive
This is not a bug, but related to the confusion on item #5 see below

2) There is no place to specify values for NameVirtualHost directive
This is not a bug, but related to the confusion on item #5 see below

3) Duplicate entries are set for TransferLog when specified
This still happens.  It's in my config, not sure if it affects anything.  Server
still runs.

4) In directory options, the word 'from' appears twice.
   eg. 'Allow from from all'
This still happens.  It's in my config, not sure if it affects anything.
eg. Allow from from all
Server still starts and runs.

5) The 'Directory Page Search List' is not transferred to the DirectoryIndex
directive.
This item #5 is probably the root cause of the problems I have had.
Site default values are not stored in http.conf file.
To reproduce
a) In KDE select Menu->System_Settings->Server-Settings->HTTP_Server
b) Select 'Virtual Host' Tab
c) Select Add to add a virtual host
d) Select 'Name based Virtual host'
e) Complete fields Virtual_Host_Name, Document_root, Webmaster_Email,
IP_Address, Server_Host_Name with valid information.
f) Select 'Site_Configuration' from list on left.
f.1) Note Directory Search Page List contains index.html, index.htm, index.shtml
f.2) Do not modify, and select OK to close window.
g) Select OK to close Apache Configuration and save.
h) Check http.conf file, note that DirectoryIndex directive does not exist in
<VirtualHost>
i) Repeat steps a-g, except on step f.2 add test.html to Directory Page Search List
J) Check http.conf file, note presence of DirectoryIndex directive that contains
 all the values from the configuration program.
Comment 2 Heinrich Morf 2003-05-13 06:49:55 EDT
I observe the same kind of errors on redhat 8.0

As a matter of fact I cannot configure Apache with the redhat-httpd-
configuration tool. :-((

Strangely, I also observe that I have to enter more and more "page down" 
strokes till I arrive at lines with text, when I am looking at httpd.config 
with "cat filename ¦ less"
Comment 3 Phil Knirsch 2004-09-01 05:36:25 EDT
I can reproduce the problem on latest Fedora Core tree and have found
the root of the problem.

I'm currently working on a fix which i hope to get in in the next version.

Read ya, Phil
Comment 4 Phil Knirsch 2004-09-01 09:30:35 EDT
*** Bug 97081 has been marked as a duplicate of this bug. ***
Comment 5 Phil Knirsch 2004-09-01 11:21:56 EDT
OK, fix is ready. Unfortunately it's not perfect, but it's the best i
can do:

If you have an "old" configuration and edit the Virtualhost where the
DirectoryIndex was listed the list is now empty. Just add the 3
entries maunally and you're set.

For new Virtualhosts everything is fine now, it will directly contain
the 3 default values.

The reason for the first "problem" is that one could (with the new
version) remove all DirectoryIndex entries on purpose (so that either
a directory listing would be displayed or a forbidden message,
depending on wether directory listings are activated or now) and i
can't tell wether it's intentional or because of the old config file
(which did display the default values but never stored them).

A new version should go out sometime in the next few days via Fedore
Core development.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.