Bug 89983 - Mkae bzImage crashes when trying to compile 2.4.20.9
Summary: Mkae bzImage crashes when trying to compile 2.4.20.9
Status: CLOSED DUPLICATE of bug 89864
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: make   
(Show other bugs)
Version: 9
Hardware: athlon
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-30 19:32 UTC by derek slayton
Modified: 2007-04-18 16:53 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:52:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description derek slayton 2003-04-30 19:32:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
When i try to compile the 2.4.20-9 kernel, the make bzImage crashes every time.

Here is the output:

gcc -D__KERNEL__ -I/usr/src/linux-2.4.20-9/include -Wall -Wstrict-prototypes
-Wno-trigraphs -O2 -fno-strict-aliasing -fno-common -fomit-frame-pointer -pipe
-mpreferred-stack-boundary=2 -march=i686   -nostdinc -iwithprefix include
-DKBUILD_BASENAME=agpgart_be  -DEXPORT_SYMTAB -c agpgart_be.c
agpgart_be.c: In function `intel_830mp_configure':
agpgart_be.c:1678: internal error: Illegal instruction
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[4]: *** [agpgart_be.o] Error 1
make[4]: Leaving directory `/usr/src/linux-2.4.20-9/drivers/char/agp'
make[3]: *** [first_rule] Error 2
make[3]: Leaving directory `/usr/src/linux-2.4.20-9/drivers/char/agp'
make[2]: *** [_subdir_agp] Error 2
make[2]: Leaving directory `/usr/src/linux-2.4.20-9/drivers/char'
make[1]: *** [_subdir_char] Error 2
make[1]: Leaving directory `/usr/src/linux-2.4.20-9/drivers'
make: *** [_dir_drivers] Error 2

Version-Release number of selected component (if applicable):
kernel-2.4.20-9

How reproducible:
Always

Steps to Reproduce:
1. install 2.4.20-9 source
2. make mrproper, make xconfig select ntfs driver, make dep
3. make bzImage
    

Actual Results:  gcc -D__KERNEL__ -I/usr/src/linux-2.4.20-9/include -Wall
-Wstrict-prototypes -Wno-trigraphs -O2 -fno-strict-aliasing -fno-common
-fomit-frame-pointer -pipe -mpreferred-stack-boundary=2 -march=i686   -nostdinc
-iwithprefix include -DKBUILD_BASENAME=agpgart_be  -DEXPORT_SYMTAB -c agpgart_be.c
agpgart_be.c: In function `intel_830mp_configure':
agpgart_be.c:1678: internal error: Illegal instruction
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[4]: *** [agpgart_be.o] Error 1
make[4]: Leaving directory `/usr/src/linux-2.4.20-9/drivers/char/agp'
make[3]: *** [first_rule] Error 2
make[3]: Leaving directory `/usr/src/linux-2.4.20-9/drivers/char/agp'
make[2]: *** [_subdir_agp] Error 2
make[2]: Leaving directory `/usr/src/linux-2.4.20-9/drivers/char'
make[1]: *** [_subdir_char] Error 2
make[1]: Leaving directory `/usr/src/linux-2.4.20-9/drivers'
make: *** [_dir_drivers] Error 2


Expected Results:  compile should have completed with no errors

Additional info:

Comment 1 Jakub Jelinek 2004-10-07 10:34:05 UTC

*** This bug has been marked as a duplicate of 89864 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:52:51 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.