Bug 89984 - snmpd does not support ipv6
Summary: snmpd does not support ipv6
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: net-snmp   
(Show other bugs)
Version: 9
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Radek Vokal
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-30 19:36 UTC by Chris Hills
Modified: 2007-04-18 16:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-17 08:56:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Hills 2003-04-30 19:36:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a)
Gecko/20030318 Phoenix/www.chaz6.com

Description of problem:
I have installed the latest net-snmp from rawhide, and snmpd does not support
ipv6. When I attempt to start it, it exits immediately, with a 'startup
successful' message.

Version-Release number of selected component (if applicable):
net-snmp-5.0.8-3

How reproducible:
Always

Steps to Reproduce:
1. Open /etc/rc.d/init.d/snmpd
2. Change the line that reads:

OPTIONS="-s -l /dev/null -P /var/run/snmpd -a"

to

OPTIONS="-s -l /dev/null -P /var/run/snmpd -a udp:161,udp6:161"

3. Run sudo /sbin/service snmpd start
    

Actual Results: 

$ sudo tail /var/log/messages

Apr 30 19:54:38 pluto net-snmp[16305]: Error opening specified endpoint "udp6:161"
Apr 30 19:54:38 pluto net-snmp[16305]: Server Exiting with code 1
Apr 30 19:54:38 pluto snmpd: snmpd startup succeeded

$ ps -ax | grep snmpd
16767 pts/5    S      0:00 grep snmpd

Expected Results: 

$ sudo tail /var/log/messages

Apr 30 20:02:12 pluto net-snmp[16450]: NET-SNMP version 5.0.6
Apr 30 20:02:13 pluto snmpd: snmpd startup succeeded

$ ps -ax | grep snmpd
16631 ?        S      0:00 /usr/sbin/snmpd -s -l /dev/null -P /var/run/snmpd -a
udp:161
16767 pts/5    S      0:00 grep snmpd


Additional info:

The message 'snmpd startup succeeded' is misleading, as it has not started at all.

Comment 1 Radek Vokal 2004-09-09 11:15:01 UTC
Is this problem still valid? Seems to be fixed.


Note You need to log in before you can comment on or make changes to this bug.