Bug 89986 - Default to being in main menu rather than More
Default to being in main menu rather than More
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: redhat-menus (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-30 16:29 EDT by Toralf
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-06 15:03:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toralf 2003-04-30 16:29:38 EDT
Description of problem:
I'm still not quite happy with the way the layout of th default Applications
menu. In far too many cases, I find that I have to look in More <Whatever> to
find what I need - even for *simple* tools or standard GNOME apps.

Based on this, I'm wondering if the current strategy of including special
keywords in desktopfiles for the "main" menu entries is such a good idea. Maybe
it would be better to mark the apps *not* allowed there in some special

Another problem is that the word "More" doesn't sufficiently describe the nature
of these submenus; I'm assuming they are meant for unusual or advanced apps, so
the menu names should reflect that. I don't really like "Advanced ...", either,
though. Something like "Supplementary ..." would perhaps be slightly better.
I'll let you know if I can think of anything really good.

Version-Release number of selected component (if applicable):
0.38-1
Comment 1 Havoc Pennington 2003-04-30 16:33:40 EDT
It's most helpful to give specific suggestions ("move XYZ to submenu Bar"), 
ideally one per bug; otherwise you end up with a bug that's just an uncloseable 
conversation about the menus, rather than an action item that can be 
implemented or not implemented and then closed.

For open-ended conversation the mailing lists are better.
Comment 2 Toralf 2003-04-30 16:42:25 EDT
Perhaps I talk too much. I should have written something like:

Application entry should be added to main menu for Cathegory, not "More" sub
menu, by default.

But maybe that's also too general, or too much a matter of opinion...
Comment 3 Havoc Pennington 2003-04-30 16:47:52 EDT
The reason for the current way is just that we want to explicitly decide to add
apps to the main menu; by default they should not be there. Otherwise, the main
menu ends up cluttered and haphazard since it hasn't been consciously planned out.

I think it'd be best to simply suggest moving anything to main menu that should be.

Note that the primary rule here is one app per category (one web browser,
one music player, etc.)
Comment 4 Toralf 2003-05-02 10:24:14 EDT
The question is really, will you ever be able to mark everything correctly. If
not, you have to choose between getting a few unwanted entries in the base menu,
and losing ones yo do want, of which the former alternative is the better, IMO.
Comment 5 Havoc Pennington 2003-10-06 15:03:37 EDT
To me the goal is to have a select small number of apps at the toplevel, and
everything else in More. So it makes sense to mark the select small number of apps.

Note You need to log in before you can comment on or make changes to this bug.