Bug 9000 - Nothing is doen with second CGSIX framebuffer
Nothing is doen with second CGSIX framebuffer
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.2
sparc Linux
medium Severity low
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-30 17:12 EST by Hans de Goede
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-18 14:51:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2000-01-30 17:12:17 EST
My sparc ipx has two CGSIX framebuffers.

The installer nor kuzdu do nothing with it.

To use it I need to create a:
/etc/x11/xinit/xserverrc

containing:
#!/bin/sh

exec X -dev /dev/fb0:/dev/fb1 "$@"

and add the -dev /dev/fb0:/dev/fb1 to the X server entry in
/etc/X11/gdm/gdm.conf
Comment 1 Bill Nottingham 2000-01-31 00:02:59 EST
What does /etc/sysconfig/hwconf look like?

In general, second graphics cards aren't configured, because trying
to do so would lead to utter chaos on Intel.
Comment 2 Hans de Goede 2000-02-01 04:26:59 EST
It does see both of them:
-
class: VIDEO
bus: SBUS
detached: 0
driver: Server:Sun
desc: "Sun|Single width GX"
width: 1152
height: 900
freq: 76
monitor: 4
-
class: VIDEO
bus: SBUS
detached: 0
driver: Server:Sun
desc: "Sun|Single width GX"
width: 1152
height: 900
freq: 76
monitor: 4
-

And configuring both is quite easy and safe on a sparc (atleast on an older
sparc with framebuffer cards, dunno about the newer sparcs with pci cards)

Al aleady said al that's needed to configure both cards on my sun is adding:
-dev /dev/fb0:/dev/fb1 to all places where x is started (xserverrc, gdm.conf,
xdm.conf, or make xdm / gdm honor xserverrc)
Comment 3 Erik Troan 2000-02-18 14:51:59 EST
We only support a single video card.

Note You need to log in before you can comment on or make changes to this bug.