Bug 90000 - xinet crashes without any reason
xinet crashes without any reason
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: xinetd (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-30 19:33 EDT by Kristian Sørensen
Modified: 2014-08-31 19:24 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-07 11:13:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kristian Sørensen 2003-04-30 19:33:14 EDT
Description of problem:
I have for some days experienced that my xinet deamon has without reason
crached. All the deamon does is spawning threads for "pop3s".

Version-Release number of selected component (if applicable):
xinetd-2.3.10-6


How reproducible:
I don't know. I have just upgraded from the Redhat Beta version to 9.0. The
problem started after this.

Steps to Reproduce:
Sorry can't help here. I am the only one using my mail-server on pop3s - so I
guess it has to be either the deamon or pop3s that makes the program fail. There
is no entrys in the log of when the xinetd has crashed.

When, however, the deamon starts, the following error is written to the log:
May  1 01:24:00 ks xinetd[9785]: pmap_set failed. service=sgi_fam program=391002
version=2
Comment 1 Steve Grubb 2003-05-02 08:38:21 EDT
My guess is that portmapper isn't running on your machine. As root, try: 

ps -ef | grep port

See if portmapper is running. If it is running, could you post the xinetd 
config for sgi_fam & pop3s. If portmapper is not running, I would disable the 
sgi_fam service. Nautilis is the only program that actually wants sgi_fam. Most 
servers never run X so it can be disabled in most cases.
Comment 2 Kristian Sørensen 2003-05-05 12:49:35 EDT
Portmapper is not running and X is required, so this is not an option.

I did not quite understand what you meant by this: "If it is (portmapper
running) running, could you post the xinetd config for sgi_fam & pop3s."
What is this - and how is it done. Would it help for me to start portmapper?
Comment 3 Steve Grubb 2003-05-05 14:32:33 EDT
>Portmapper is not running and X is required

This is your problem. Start portmap like so: /etc/rc.d/init.d/portmap start

Then you can re-test xinetd.

To make it automatically start on boot: /sbin/chkconfig --level 5 portmap on

sgi_fam is trying to register with the portmapper daemon and it wasn't running.
Xinetd was simply reporting sgi_fam not being able to do so. I don't know if
this solves the ultimate problem of xinetd crashing, but it should get rid of
the sgi_fam message. 

If you still have a problem, what does crashing mean? Has xinetd exited? How
long does it take before it crashes? The pop3 configuration would be in either
/etc/xinetd.conf or /etc/xinetd.d/(program or service name). Look for something
with port = pop3 or port = 110.
Comment 4 Kristian Sørensen 2003-05-08 03:54:19 EDT
The problem is very sporatic. I have not experienced it in the past 5 days or so.

>If you still have a problem, what does crashing mean?
This means that xinetd stops suddenly without any warning messages in any log
files ect.

>Has xinetd exited?
yes.

>How long does it take before it crashes?
The computer is actually also my workstation, and I have installed Postfix as
MTA for testing purposes. The computer is only running in the daytime, as I am
the onlyone who send mail to my own mailserver.

The reason I discovered that Xinetd stops is that I use Xinetd to spawn
pop3s-threads for my e-mail program.

The times Xinetd has stoped, my computer have been running for 4-6 hours - but
the MTA has not in any way been hard loaded!

I don't know how we are to get closer on this problem. If I observe new stuff
regarding this, I will post it for you.
Comment 5 Jay Fenlason 2003-05-08 17:33:27 EDT
Can you try the errata candidate xinetd that's currently going through QA here?
 I put a copy in
http://people.redhat.com/fenlason/.xinetd/xinetd-2.3.11-1.9.0.i386.rpm
It has a fair number of bugfixes over the 2.3.10 version that was shipped with
Red Hat Linux 9.
Comment 6 Jay Fenlason 2003-08-07 11:13:28 EDT
Closing this since the submitter hasn't responded and the errata went out.

Note You need to log in before you can comment on or make changes to this bug.