Bug 90030 - top prints PRI as int rather than signd int
Summary: top prints PRI as int rather than signd int
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: procps (Show other bugs)
(Show other bugs)
Version: 9
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
: 103648 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-01 13:22 UTC by Gerald Teschl
Modified: 2007-04-18 16:53 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-25 08:54:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gerald Teschl 2003-05-01 13:22:32 UTC
Description of problem:
top shows a quite high priority for mdrecoveryd;-)

 PID USER     PRI  NI  SIZE  RSS SHARE STAT %CPU %MEM   TIME CPU COMMAND

<snip>
    6 root       9   0     0    0     0 SW    0.0  0.0   0:00   0 kupdated
   16 root     18446744073709551615 -20     0    0     0 SW<   0.0  0.0   0:00 
 0 mdrecoveryd
   17 root       9   0     0    0     0 SW    0.0  0.0   0:20   0 kswsuspd


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. top
2.
3.
    
Actual results:
PRI = 18446744073709551615

Expected results:
 -1 in stead of 2^64-1

Additional info:
ps shows PRI = -1

Comment 1 Gerald Teschl 2003-05-01 13:23:21 UTC
Forgot to metntion: procps-2.0.11-6


Comment 2 Alexander Larsson 2003-05-16 09:36:10 UTC
This was fixed in 2.0.12, so we'll get it on the next update.


Comment 3 Alexander Larsson 2003-09-25 09:01:21 UTC
*** Bug 103648 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.