Bug 90052 - Mailman 2.1 will not start
Summary: Mailman 2.1 will not start
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mailman   
(Show other bugs)
Version: 9
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: John Dennis
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-01 18:11 UTC by Kevin Chu
Modified: 2007-04-18 16:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-24 19:18:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2003:179 normal SHIPPED_LIVE Mailman RPM does not properly handle package installation and upgrade. 2003-09-24 04:00:00 UTC

Description Kevin Chu 2003-05-01 18:11:38 UTC
Description of problem:
When trying to start Mailman 2.1-8, I get the following errors:
[root@linux root]# service mailman start
Traceback (most recent call last):
  File "/var/mailman/bin/mailmanctl", line 524, in ?
    main()
  File "/var/mailman/bin/mailmanctl", line 319, in main
    check_privs()
  File "/var/mailman/bin/mailmanctl", line 274, in check_privs
    gid = grp.getgrnam(mm_cfg.MAILMAN_GROUP)[2]
KeyError: getgrnam(): name not found


Version-Release number of selected component (if applicable):
mailman-2.1-8

How reproducible:
Every attempt produces same results.

Steps to Reproduce:
1. # service mailman start
    
Actual results:
See above.

Expected results:
mailman qrunner start

Additional info:
System is up2date with RHN.  Mailman useraccount exists:
mailman:x:41:41:GNU Mailing List Manager:/var/mailman:/bin/false
as does mailman group:
mailman:x:41:

Comment 1 John Dennis 2003-05-01 18:49:02 UTC
this problem and a few others are fixed in the current rpm on rawhide,
ftp://ftp.redhat.com/pub/redhat/linux/rawhide

mailman-2.1.1-3

*** This bug has been marked as a duplicate of 89695 ***

Comment 2 John Dennis 2003-09-24 19:18:42 UTC
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-179.html



Note You need to log in before you can comment on or make changes to this bug.