Bug 90068 - OpenSSL upgrade prevents KDE/konqueror from loading secure sites
OpenSSL upgrade prevents KDE/konqueror from loading secure sites
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kdelibs (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-01 19:13 EDT by NILMONI DEB
Modified: 2007-04-18 12:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-13 17:42:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description NILMONI DEB 2003-05-01 19:13:10 EDT
Description of problem: 
After installing RH9 on my Pentium-3 laptop, kde/konqueror could load https 
sites (like https://rhn.redhat.com/errata/rh9-errata.html ) just fine. Then I 
applied all upgrades including openssl-0.9.7a-5 (i686 rpm) and konqueror 
failed to load these secure sites.  
 
I went to konqueror settings -> crypto -> openssl and clicked on the test 
button only to get the error message that openssl could not be loaded. 
So I went ahead and installed openssl096b-0.9.6b-6 and then OpenSSL was 
successfully loaded and konqueror could again load https sites. 
 
However: 
 
1. "rpm -e --test openssl096b" shows no error messages 
 
2. "rpm -q --whatrequires openssl096b" says-> 
 
no package requires openssl096b 
 
On the other hand, 
 
3. "rpm -q --whatrequires openssl" says: 
w3m-0.3.2.2-5 
libpcap-0.7.2-1 
 
Firstly, why did an upgrade of openssl stop konqueror from loading secure 
sites ? 
 
Secondly, if no package needs openssl096b, how can it solve konqueror's secure 
site loading problem ? 
 
Version-Release number of selected component (if applicable): 
 
 
How reproducible: 
 
Tried only once. 
 
Steps to Reproduce: 
1.See above 
2. 
3. 
     
Actual results: 
 
KDE seems to depend on the wrong openssl package 
 
Expected results: 
 
KDE should depend on the correct openssl package 
 
Additional info:
Comment 1 Ngo Than 2003-05-08 06:28:58 EDT
It works for me. You should restart your KDE desktop after upgrade process.
Comment 2 Tim Landscheidt 2003-05-12 19:26:54 EDT
IBTD: With kdebase-3.1-12, kdelibs-3.1-10 and openssl-0.9.7a-5, all https connection attempts 
fail (without any network activitiy). Toss in openssl096b-0.9.6b-3, and everything's fine. 
Comment 3 NILMONI DEB 2003-05-12 22:25:18 EDT
Someone please reopen this bug. 
Comment 4 Ngo Than 2003-05-13 05:37:08 EDT
I think, i have found the bug. I can reproduce this problem on my machine now.
The Problem is that the konqueror tries to open libssl.so, which does not exist
on your machine after update process.

Could you please check if the symlink /libssl.so -> ../../lib/libssl.so.0.9.7a
exists on your machine? If not, please install it, and try again. I should work.
Comment 5 NILMONI DEB 2003-05-13 12:36:03 EDT
> If not, please install it, and try again. I should work. 
Are you asking me to reinstall the openssl-0.9.7a-5 rpm ? As I have already said, 
installing openssl096b-0.9.6b fixes the problem. 
 
In any case, is this a packaging bug then ? 
Comment 6 Ngo Than 2003-05-13 17:42:43 EDT
it's a bug in kdelibs. i have fix it in kdelibs-3.1.2-2 or newer.
Comment 7 NILMONI DEB 2003-05-13 18:23:19 EDT
> i have fix it in kdelibs-3.1.2-2 or newer. 
 
Is KDE 3.1.2 out yet ? In any case, where can I get these new rpms ? 
Comment 8 Ngo Than 2003-05-14 05:32:21 EDT
kde 3.1.2 will probably be available this weekend on ftp.kde.org.

Note You need to log in before you can comment on or make changes to this bug.