Bug 90071 - Cannot stop bind with rndc
Cannot stop bind with rndc
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: bind (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-01 19:54 EDT by Eric Yeo
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-01 23:27:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Yeo 2003-05-01 19:54:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
Bind on Redhat 9 cannot be stopped by "rndc -y rndckey stop". The following
message appears in the logs:

May  2 09:46:09 xxxxx named[3632]: app.c:561: unexpected error:
May  2 09:46:09 xxxxx named[3632]: isc_app_shutdown() pthread_kill: No such process

Using rndc to stop Bind is very important in an environment where the zones are
update dynamically because it gets Bind to write out the zone file for manual
modification.


Version-Release number of selected component (if applicable):
bind-9.2.1-16

How reproducible:
Always

Steps to Reproduce:
1.rndc -y rndckey stop
    

Actual Results:  The named process does not stop and the following logs appear:

May  2 09:46:09 xxxxx named[3632]: app.c:561: unexpected error:
May  2 09:46:09 xxxxx named[3632]: isc_app_shutdown() pthread_kill: No such process


Expected Results:  The named process should terminate.


Additional info:

The keys has been configured properly.
Comment 1 Daniel Walsh 2003-05-01 23:27:31 EDT
This is a known problem.  Please upgrade to latest kernel errata.  You might
want to upgrade to bind*9.2.2 also 

Note You need to log in before you can comment on or make changes to this bug.