Bug 9009 - /etc/ppp/ip-up calls ifup-post with unset variable
/etc/ppp/ip-up calls ifup-post with unset variable
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: isdn4k-utils (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-30 21:08 EST by Andrew Meredith
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-04 11:19:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/ppp/ip-up after change noted in my report (409 bytes, text/plain)
2000-01-30 21:10 EST, Andrew Meredith
no flags Details

  None (edit)
Description Andrew Meredith 2000-01-30 21:08:36 EST
ifup-post is called by ip-up using the variable LOGDEVICE, which is set
from $6, which is unset. This leads to ifup-post not functioning correctly.

Maybe it should read

 /etc/sysconfig/network-scripts/ifup-post ifcfg-${REALDEVICE}

Where REALDEVICE is $1, which is the actual device name. I have made this
substitution in my system and this seems to make things work as I believe
they are intended.

If I have this wrong (not unlikely) I would be grateful for any pointers.

Cheers

Andy Meredith

PS I am using:

Name        : initscripts                  Relocations: (not relocateable)
Version     : 4.70                              Vendor: Red Hat, Inc.
Release     : 1                             Build Date: Tue 30 Nov 1999
07:51:55 PM GMT
Install date: Sat 18 Dec 1999 12:43:25 PM GMT      Build Host:
porky.devel.redhat.com
Group       : System Environment/Base       Source RPM:
initscripts-4.70-1.src.rpm
Size        : 248781                           License: GPL
Packager    : Red Hat, Inc. <http://developer.redhat.com/bugzilla>
Summary     : The inittab file and the /etc/rc.d scripts.
Comment 1 Andrew Meredith 2000-01-30 21:10:59 EST
Created attachment 85 [details]
/etc/ppp/ip-up after change noted in my report
Comment 2 Nalin Dahyabhai 2000-02-01 16:47:59 EST
Please verify that the DEVICE variable is set in
/etc/sysconfig/network-scripts/ifcfg-???.  The sixth
parameter is set when ifup-ppp adds "ipparam $DEVICE"
to the list of options passed to pppd, and pppd should
then pass it along to ip-up as $6.
Comment 3 Andrew Meredith 2000-02-02 10:52:59 EST
Oops .. I just reread my initial comments and realised I hadn't mentioned that
it is using the ISDN ipppd not the original pppd.

Andy Meredith <andrew@anvil.org>
Comment 4 Nalin Dahyabhai 2000-02-04 22:42:59 EST
Changed component to isdn4k-utils.
Comment 5 Ngo Than 2000-07-04 11:19:30 EDT
it was fixed in the rawhide
Comment 6 Ngo Than 2000-07-04 11:20:47 EDT
it was fixed in the rawhide

Note You need to log in before you can comment on or make changes to this bug.