Bug 90091 - /etc/rc calls /usr/bin/rhgb-client which does not exist
/etc/rc calls /usr/bin/rhgb-client which does not exist
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: initscripts (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
: 90196 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-02 08:08 EDT by Kaj J. Niemi
Modified: 2014-03-16 22:36 EDT (History)
2 users (show)

See Also:
Fixed In Version: 7.20-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-05 12:16:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaj J. Niemi 2003-05-02 08:08:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030303

Description of problem:
initscripts-7.18-1 provided /etc/rc calls on line 81 /usr/bin/rhgb-client which
does not exist by default nor does initscripts require a package providing
rhgb-client.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install initscripts
2.
3.


Actual Results:  A lot of errors about a missing file on line 81 in /etc/rc on
startup/shutdown.

Expected Results:  No errors. ;-)

Additional info:

Fix /etc/rc line 81 to:

[ -x /usr/bin/rhgb-client ] && /usr/bin/rhgb-client --update "$subsys"

or have initscripts require the real package providing rhgb-client.
Comment 1 Bill Nottingham 2003-05-02 11:02:23 EDT
A bad patch got applied, fixed differently in CVS, will be in 7.19-1.
Comment 2 Need Real Name 2003-05-04 08:05:50 EDT
apparently it was missed for 7.19-1, because the error messages are still there
after upgrading
Comment 3 Bill Nottingham 2003-05-05 12:15:04 EDT
Odd, will be fixed in 4.20-1.
Comment 4 Bill Nottingham 2003-05-05 12:18:18 EDT
*** Bug 90196 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.