Bug 90102 - Systems errata is not shown as errata after manual 'up2date -p' anymore
Systems errata is not shown as errata after manual 'up2date -p' anymore
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
unspecified
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mihai Ibanescu
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-02 10:53 EDT by Christian Stelter
Modified: 2007-07-31 15:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-06 04:34:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Errata displayed before up2date -p (187.82 KB, image/png)
2003-05-02 10:54 EDT, Christian Stelter
no flags Details
Errata displayed after up2date -p (168.80 KB, image/png)
2003-05-02 10:55 EDT, Christian Stelter
no flags Details
Package list after up2date -p (175.18 KB, image/png)
2003-05-02 10:57 EDT, Christian Stelter
no flags Details

  None (edit)
Description Christian Stelter 2003-05-02 10:53:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021202

Description of problem:
After removing the sendmail rpm locally (was replaced by a qmail) and updating
the system's profile mit 'up2date -p' the previously shown erratas are not
longer shown as erratas in the system details on our satellite server.

I've reproduced this effect on two other systems. The result is attached as
screenshots. Also this test systems have sendmail and should see the sendmail
errata for example.

When I look for update with 'up2date -l' there is no difference. On the
satellite server I find the erratas under the outstanding package updates under
system details.

Version-Release number of selected component (if applicable):
rhns-server-1.2.6.1-5 rhnproc-0.7-1

How reproducible:
Always

Steps to Reproduce:
1. lookup the erratas of a system under system details 
2. perform an up2date -p on the system
3. lookup up the erratas of a system under system details again
    

Actual Results:  erratas are missing

Expected Results:  same erratas as in 1.


Additional info:

Look's like some relations in the database are lost after an 'up2date -p'.
Comment 1 Christian Stelter 2003-05-02 10:54:58 EDT
Created attachment 91473 [details]
Errata displayed before up2date -p
Comment 2 Christian Stelter 2003-05-02 10:55:55 EDT
Created attachment 91474 [details]
Errata displayed after up2date -p
Comment 3 Christian Stelter 2003-05-02 10:57:10 EDT
Created attachment 91475 [details]
Package list after up2date -p
Comment 4 Bret McMillan 2003-05-02 12:21:24 EDT
Cristian, I'm a little bit confused.  Let me ask a few questions:

1.  Did you remove the sendmail package from system lnxc-329 before the first
attachment image was taken?  And then ran the up2date -p?

2.  Is the package list on the website for the system correct compared to the
results of rpm -qa ?

Comment 5 Christian Stelter 2003-05-05 04:02:10 EDT
1. No. lnxc-329 does still have a sendmail package. On the first system where I
saw the problem I removed the sendmail packages, before I issued an 'up2date
-p'. After I noticed the errata problem, I verified it on two other machines.
One of those other machines was the lnxc-329.

2. At least the package count is identical (360 packages). Is there a way to
extract the packages list from the Satellite database to a text file? Then I
could make a diff. 
Comment 6 Christian Stelter 2003-05-06 04:34:16 EDT
The problem is solved although we're not 100% sure what the problem was. It
seems that the oracle database was the problem. After experiencing some
performance problems one of our database administrators checked the database and
noticed a long running checkpoint process. He also rebuilded the database
statistics.

After that I checked the lnxc-329 profile and got it's errata displayed. Last
time I checked this was yesterday. So I not sure whether the restart or some
other process solved the errata problem.

Note You need to log in before you can comment on or make changes to this bug.