This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 90107 - Copy and paste files works/fails inconsistently
Copy and paste files works/fails inconsistently
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: nautilus (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
Jay Turner
:
: 90620 106036 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-02 12:36 EDT by Alex Deucher
Modified: 2015-01-07 19:04 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-04 09:29:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Deucher 2003-05-02 12:36:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

Description of problem:
If I open up two nautilus windows and in one I select several files and choose
"edit" | "copy files" and then select the other nautilus window and select
"edit" | "paste files"  I cannot select it because it is greyed out.  if I
select all the files and then drag them from one window to the other the copy
works.  from then on using the copy and paste file menus between the two windows
work.  From then on the behavior is continues to be inconsistent.  I've noticed
this behavior in nautilus for a while now(redhat 7.3, 8.0).

Version-Release number of selected component (if applicable):
Nautilus-2.2.1-5

How reproducible:
Sometimes

Steps to Reproduce:
1. open up two nautilus windows and in one select several files 
2. choose "edit" | "copy files" from the menu bar
3. select the other nautilus window
4. select "edit" | "paste files"  you cannot select it because it is greyed out.  
    

Actual Results:  I cannot paste the files.  if I select all the files and then
drag them from one window to the other the copy works.  from then on using the
copy and paste file menus between the two windows work.  If I close the windows
 and open new ones and try again, the behavior is continues to be inconsistent.  

Expected Results:  the files should copy

Additional info:
Comment 1 Alexander Larsson 2003-05-16 08:25:05 EDT
Yes. This is due to a fundamental feature missing from X. You can't know when
the selection changes. This was fixed with the XFIXES extension, but that didn't
go into XFree86 4.3.0 unfortunately, so we'll have to wait a while for this to
get fixed.

As a workaround, click on a file in the window you want to paste in. That should
make the paste menu item un-grey.
Comment 2 Alexander Larsson 2003-05-28 06:52:03 EDT
*** Bug 90620 has been marked as a duplicate of this bug. ***
Comment 3 Alexander Larsson 2003-10-06 11:51:43 EDT
*** Bug 106036 has been marked as a duplicate of this bug. ***
Comment 4 Alexander Larsson 2004-10-04 09:29:56 EDT
This is working pretty well in gnome 2.8, so i'm closing it. For
out-of-process clipboard owner changes we need xfixes though. But
thats for 2.10.

Note You need to log in before you can comment on or make changes to this bug.