Bug 90114 - Alt-Gr does not work on Norwegian keyboard after default loaded
Alt-Gr does not work on Norwegian keyboard after default loaded
Status: CLOSED DUPLICATE of bug 106171
Product: Red Hat Linux
Classification: Retired
Component: gnome-applets (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
Mike McLean
: MoveUpstream, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-02 14:21 EDT by Toralf
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:52:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toralf 2003-05-02 14:21:19 EDT
Description of problem:
Alt Gr key does not work when using Norwegian keyboard with Xkb layout set to
"no" in XF68Config

Version-Release number of selected component (if applicable):
4.3.0-2

How reproducible:
Every time

Steps to Reproduce:
1. Add
  Option "XkbLayout" "no"
to XF86Config (by hand or via config tools.)
2. Log in
3. Press <Alt Gr> + 2 while text input field has focus
    
Actual results:
Character '@' inserted

Expected results:
No character retured.

Additional info:
Comment 1 Toralf 2003-05-02 14:25:50 EDT
Workaround:

gkb_xmmap no

after login; keyboard layout switcher may be set up to do this automatically.

Comment 2 Toralf 2003-05-02 14:46:49 EDT
Actually, it turns out that the keyboard layout switcher applet does this; Alt
Gr functionality is lost after Keymap is set to "Gnome Keyboard Default", which
is what the applet does on startup in the default setup.
Comment 3 Toralf 2003-10-03 10:47:36 EDT
Unfortunately, gkb_xmmap causes other problems - see bug 106172.
Comment 4 Toralf 2003-10-09 02:18:38 EDT

*** This bug has been marked as a duplicate of 106171 ***
Comment 5 Toralf 2003-10-09 02:21:40 EDT
Marked as duplicate of bug 106171 as there is more of a general problem with the
applet and its supplied keymaps.
Comment 6 Toralf 2003-10-09 02:23:12 EDT
And that should be bug 106171 (not 106172) in all my above notes.
Comment 7 Red Hat Bugzilla 2006-02-21 13:52:52 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.