Bug 901254 (JBPAPP6-1708) - Failing crash recovery tests on MSSQL 2008
Summary: Failing crash recovery tests on MSSQL 2008
Keywords:
Status: CLOSED CANTFIX
Alias: JBPAPP6-1708
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Transaction Manager
Version: 6.0.1
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Ondrej Chaloupka
QA Contact:
URL: http://jira.jboss.org/jira/browse/JBP...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-10 16:08 UTC by Ondrej Chaloupka
Modified: 2013-06-19 07:43 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-06-19 07:43:35 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
JBoss Issue Tracker JBPAPP6-1708 Major Closed Failing crash recovery tests on MSSQL 2008 2016-08-10 20:35:01 UTC

Description Ondrej Chaloupka 2012-12-10 16:08:22 UTC
Affects: Documentation (Ref Guide, User Guide, etc.)
project_key: JBPAPP6

This bug refers to JBPAPP-8983 (Regression in crash recovery tests on MSSQL 2008) where was found out that crash recovery test prepareHalt fails for both JTA/JTS on EAP 6.0.0 and the reason was (probably) a bug in mssql jdbc driver. The tests were run on driver version 3.0.x

For EAP 6.0.1 we started to use driver version 4.0.x where it was supposed that this problem won't occur anymore but the problem stays.

Comment 4 tom.jenkinson 2012-12-11 13:44:32 UTC
Hi Ondra, I pushed an update of the test and that proves conclusively to me that the formatId is still zero. Please can you verify you agree and then can you escalate it as appropriate?

Thanks,
Tom

Comment 6 Ondrej Chaloupka 2012-12-12 14:42:08 UTC
Release Notes Docs Status: Added: Not Yet Documented
Affects: Added: Documentation (Ref Guide, User Guide, etc.)


Comment 7 Ondrej Chaloupka 2012-12-13 16:37:37 UTC
The problem occurs on R2 as well. The problem does not occurs on 2012.

I've created a bugzilla for this problem being documented in release notes:
https://bugzilla.redhat.com/show_bug.cgi?id=886950

Comment 8 Ondrej Chaloupka 2013-04-05 08:38:46 UTC
The problem with incorrect XID format was fixed in MSSQL 2008R2 SP2. 
For the MSSQL 2008R1 this problem lasts.

Comment 9 Paul Gier 2013-06-18 22:00:48 UTC
Ondrej, is there any work that still needs to be done on this?  Or can it be closed?

Comment 10 Ondrej Chaloupka 2013-06-19 07:43:35 UTC
Hi Paul,

there is no work that could be done. It was found that it's problem on MSSQL side which was fixed with SP2 in 2008R2. The problem remains for 2008R1.
The documentation jira was created to be this fact mentioned in release notes.

I think that this jira could be closed as I'm doing so. I put it as 'CANTFIX'. If you think that the status should be different, please, change it. Thanks.


Note You need to log in before you can comment on or make changes to this bug.