Bug 90153 - Control panel and configuration options confusingly spread out
Control panel and configuration options confusingly spread out
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: redhat-menus (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-03 12:04 EDT by Mitsu Hadeishi
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-03 12:29:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mitsu Hadeishi 2003-05-03 12:04:49 EDT
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.1; Linux) 
 
Description of problem: 
This is really a general UI design wish which affects all control panels and configuration 
tools, but I will put it here.  Right now, configuration options are confusingly spread out in 
different menus and sections, divided into "tools", control panels, configuration options, 
etc.  From the point of view of the average user, however, they do not care about the 
distinction between a "tool" and a "control panel".  I would like to suggest that all 
configuration options and tools at the very least be centralized into a single menu, or at 
least accessible from one place. 
 
What adds to the confusion is the multiple different ways of configuring the same 
device.  Red Hat allows you to look at, for example, the hard drive partitions but you 
cannot then launch a hard drive partition tool from there.  Or you can  configure the 
mouse driver but not configure the other mouse options --- that's a separate tool. 
 
I realize some of this comes from the fact that some configuration options are part of 
GNOME or KDE, but this doesn't explain why the configuration tools are spread out 
between different far-separated menus. 
 
Both Windows and the Mac provide a single control panel or "system preferences" 
launching pad from which other configuration options can be selected and/or 
configured.  It seems to me that if we want Linux to succeed with ordinary users, we 
need to try at least to some extent to consolidate the control panel/configuration 
options. 
 
Version-Release number of selected component (if applicable): 
 
 
How reproducible: 
Always
Comment 1 Havoc Pennington 2003-05-03 12:29:23 EDT
There's a long term plan to work on this, but it's a multi-year iterative 
process, not a single task that could ever be fully closed as a bugzilla bug. 
So I'm going to close this bug, but yes the problem is known.

Note You need to log in before you can comment on or make changes to this bug.