Bug 901558 - Shouldn't qemu-kvm have a versioned dependency on qemu-kvm-common?
Shouldn't qemu-kvm have a versioned dependency on qemu-kvm-common?
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Miroslav Rezanina
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-18 08:52 EST by Richard W.M. Jones
Modified: 2014-06-17 23:21 EDT (History)
6 users (show)

See Also:
Fixed In Version: qemu-kvm-1.4.0-2.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 07:28:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2013-01-18 08:52:58 EST
Description of problem:

I got this error when updating from qemu-kvm 1.2.0-21.el7 to
1.3.0-3.el7:

Transaction Check Error:
  file /usr/bin/qemu-nbd from install of qemu-img-2:1.3.0-3.el7.x86_64 conflicts with file from package qemu-kvm-common-2:1.2.0-21.el7.x86_64
  file /usr/share/man/man8/qemu-nbd.8.gz from install of qemu-img-2:1.3.0-3.el7.x86_64 conflicts with file from package qemu-kvm-common-2:1.2.0-21.el7.x86_64

The reason is that qemu-kvm doesn't seem to contain a
versioned dependency on qemu-kvm-common (or indeed *any*
dependency at all):

$ rpm -qR qemu-kvm|grep common
[no output!]

I'm pretty sure there should be a dependency there.  Indeed,
manually adding qemu-kvm-common fixed my initial problem.

Version-Release number of selected component (if applicable):

qemu-kvm 2:1.3.0-3.el7
Comment 2 Richard W.M. Jones 2013-01-18 09:22:15 EST
Maybe I'm wrong about this (Fedora qemu doesn't have a
versioned dependency either), but it does seem as if
a dependency is required.
Comment 3 Michal Novotny 2013-02-28 12:19:41 EST
(In reply to comment #2)
> Maybe I'm wrong about this (Fedora qemu doesn't have a
> versioned dependency either), but it does seem as if
> a dependency is required.

Well, I don't know yet so we need to investigate a little more. However, first we need to rebase to qemu-1.4 and fix 912433 and then we need to go on. The rebase can change several things so I'd rather wait till we rebase to qemu-1.4.

Michal
Comment 4 Miroslav Rezanina 2013-06-18 09:57:19 EDT
This was fixed in qemu-kvm-1.4.0-2.el7
Comment 6 Shaolong Hu 2014-01-17 00:35:37 EST
Verified on qemu-kvm-rhev = 10:1.5.3-31.el7:

[root@localhost ~]# rpm -qR qemu-kvm-rhev |grep common
qemu-kvm-common-rhev = 10:1.5.3-31.el7
Comment 7 Ludek Smid 2014-06-13 07:28:52 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.