Bug 901569 - libvirt broken dependencies in Rawhide prevent building libguestfs
libvirt broken dependencies in Rawhide prevent building libguestfs
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-18 09:34 EST by Richard W.M. Jones
Modified: 2013-01-21 12:03 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-21 12:03:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2013-01-18 09:34:22 EST
Description of problem:

DEBUG util.py:257:  Error: Package: libvirt-daemon-driver-network-1.0.1-2.fc19.x86_64 (build)
DEBUG util.py:257:             Requires: libnl-route-3.so.200()(64bit)
DEBUG util.py:257:  Error: Package: libvirt-daemon-1.0.1-2.fc19.x86_64 (build)
DEBUG util.py:257:             Requires: libnl-route-3.so.200()(64bit)
DEBUG util.py:257:  Error: Package: libvirt-client-1.0.1-2.fc19.x86_64 (build)
DEBUG util.py:257:             Requires: libnl-3.so.200()(64bit)
DEBUG util.py:257:  Error: Package: netcf-libs-0.2.3-1.fc19.x86_64 (build)
DEBUG util.py:257:             Requires: libnl-3.so.200()(64bit)
DEBUG util.py:257:  Error: Package: libvirt-daemon-driver-qemu-1.0.1-2.fc19.x86_64 (build)
DEBUG util.py:257:             Requires: libnl-3.so.200()(64bit)
DEBUG util.py:257:  Error: Package: libvirt-daemon-driver-network-1.0.1-2.fc19.x86_64 (build)
DEBUG util.py:257:             Requires: libnl-3.so.200()(64bit)
DEBUG util.py:257:  Error: Package: libvirt-daemon-1.0.1-2.fc19.x86_64 (build)
DEBUG util.py:257:             Requires: libnl-3.so.200()(64bit)
DEBUG util.py:257:  Error: Package: libvirt-client-1.0.1-2.fc19.x86_64 (build)
DEBUG util.py:257:             Requires: libnl-route-3.so.200()(64bit)
DEBUG util.py:257:  Error: Package: libvirt-daemon-driver-nwfilter-1.0.1-2.fc19.x86_64 (build)
DEBUG util.py:257:             Requires: libnl-route-3.so.200()(64bit)
DEBUG util.py:257:  Error: Package: netcf-libs-0.2.3-1.fc19.x86_64 (build)
DEBUG util.py:257:             Requires: libnl-route-3.so.200()(64bit)
DEBUG util.py:257:  Error: Package: libvirt-daemon-driver-nwfilter-1.0.1-2.fc19.x86_64 (build)
DEBUG util.py:257:             Requires: libnl-3.so.200()(64bit)
DEBUG util.py:257:  Error: Package: libvirt-daemon-driver-qemu-1.0.1-2.fc19.x86_64 (build)
DEBUG util.py:257:             Requires: libnl-route-3.so.200()(64bit)
(full log here:
http://kojipkgs.fedoraproject.org//work/tasks/731/4880731/root.log )

Version-Release number of selected component (if applicable):

libvirt 1.0.1-2.fc19
Comment 1 Daniel Berrange 2013-01-18 15:28:33 EST
Built 1.0.1-3.fc19
Comment 2 Richard W.M. Jones 2013-01-20 06:04:02 EST
It was briefly working yesterday afternoon after you
did that build, but it's broken again now:

DEBUG util.py:257:  Error: Package: libvirt-daemon-driver-qemu-1.0.1-3.fc19.x86_64 (build)
DEBUG util.py:257:             Requires: libnl-3.so.201()(64bit)
DEBUG util.py:257:  Error: Package: libvirt-daemon-driver-qemu-1.0.1-3.fc19.x86_64 (build)
DEBUG util.py:257:             Requires: libnl-route-3.so.201()(64bit)
DEBUG util.py:257:  Error: Package: libvirt-daemon-driver-nwfilter-1.0.1-3.fc19.x86_64 (build)
DEBUG util.py:257:             Requires: libnl-3.so.201()(64bit)
DEBUG util.py:257:  Error: Package: libvirt-daemon-driver-network-1.0.1-3.fc19.x86_64 (build)
DEBUG util.py:257:             Requires: libnl-route-3.so.201()(64bit)
DEBUG util.py:257:  Error: Package: libvirt-daemon-driver-nwfilter-1.0.1-3.fc19.x86_64 (build)
DEBUG util.py:257:             Requires: libnl-route-3.so.201()(64bit)
DEBUG util.py:257:  Error: Package: netcf-libs-0.2.3-2.fc19.x86_64 (build)
DEBUG util.py:257:             Requires: libnl-3.so.201()(64bit)
DEBUG util.py:257:  Error: Package: libvirt-daemon-driver-network-1.0.1-3.fc19.x86_64 (build)
DEBUG util.py:257:             Requires: libnl-3.so.201()(64bit)
DEBUG util.py:257:  Error: Package: libvirt-client-1.0.1-3.fc19.x86_64 (build)
DEBUG util.py:257:             Requires: libnl-route-3.so.201()(64bit)
DEBUG util.py:257:  Error: Package: netcf-libs-0.2.3-2.fc19.x86_64 (build)
DEBUG util.py:257:             Requires: libnl-route-3.so.201()(64bit)
DEBUG util.py:257:  Error: Package: libvirt-client-1.0.1-3.fc19.x86_64 (build)
DEBUG util.py:257:             Requires: libnl-3.so.201()(64bit)
DEBUG util.py:257:  Error: Package: libvirt-daemon-1.0.1-3.fc19.x86_64 (build)
DEBUG util.py:257:             Requires: libnl-3.so.201()(64bit)
DEBUG util.py:257:  Error: Package: libvirt-daemon-1.0.1-3.fc19.x86_64 (build)
DEBUG util.py:257:             Requires: libnl-route-3.so.201()(64bit)

http://kojipkgs.fedoraproject.org//work/tasks/6915/4886915/root.log
Comment 3 Richard W.M. Jones 2013-01-20 06:04:59 EST
Presumably because of this build of libnl3:
http://koji.fedoraproject.org/koji/buildinfo?buildID=379460

I wonder if we can persuade upstream libnl not to have such
a stupid soname policy?
Comment 4 Richard W.M. Jones 2013-01-20 15:11:36 EST
I just kicked off another build of netcf and libvirt
which should fix this.
Comment 5 Richard W.M. Jones 2013-01-21 12:03:29 EST
This should all be fixed now, so closing.

Note You need to log in before you can comment on or make changes to this bug.