Bug 901598 - [abrt] yum-3.4.3-30.fc17: yumRepo.py:387:_ui_id:TypeError: argument of type 'Undefined' is not iterable
[abrt] yum-3.4.3-30.fc17: yumRepo.py:387:_ui_id:TypeError: argument of type '...
Status: CLOSED DUPLICATE of bug 870691
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
abrt_hash:73f8db921d3e2c2485488f82547...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-18 10:39 EST by edo
Modified: 2013-01-18 10:43 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-18 10:43:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.03 KB, text/plain)
2013-01-18 10:39 EST, edo
no flags Details
File: core_backtrace (521 bytes, text/plain)
2013-01-18 10:39 EST, edo
no flags Details
File: environ (2.43 KB, text/plain)
2013-01-18 10:39 EST, edo
no flags Details
File: smolt_data (3.06 KB, text/plain)
2013-01-18 10:39 EST, edo
no flags Details

  None (edit)
Description edo 2013-01-18 10:39:42 EST
Version-Release number of selected component:
yum-3.4.3-30.fc17

Additional info:
cmdline:        /usr/bin/python /bin/yum repolist all
executable:     /bin/yum
kernel:         3.6.10-2.fc17.x86_64
uid:            0

Truncated backtrace:
yumRepo.py:387:_ui_id:TypeError: argument of type 'Undefined' is not iterable

Traceback (most recent call last):
  File "/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 319, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 144, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 485, in doCommands
    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
  File "/usr/share/yum-cli/yumcommands.py", line 1974, in doCommand
    rid = repo.ui_id # can't use str()
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 387, in _ui_id
    if '$releasever' in val:
TypeError: argument of type 'Undefined' is not iterable

Local variables in innermost frame:
self: <yum.yumRepo.YumRepository object at 0x1ee3f10>
val: <iniparse.config.Undefined object at 0x21e0710>
section_id: 'InstallMedia'
ret: 'InstallMedia'
ini: <iniparse.ini.INISection object at 0x335afd0>

Potential duplicate: bug 870691
Comment 1 edo 2013-01-18 10:39:46 EST
Created attachment 682486 [details]
File: backtrace
Comment 2 edo 2013-01-18 10:39:48 EST
Created attachment 682488 [details]
File: core_backtrace
Comment 3 edo 2013-01-18 10:39:50 EST
Created attachment 682489 [details]
File: environ
Comment 4 edo 2013-01-18 10:39:52 EST
Created attachment 682491 [details]
File: smolt_data
Comment 5 Zdeněk Pavlas 2013-01-18 10:43:04 EST

*** This bug has been marked as a duplicate of bug 870691 ***

Note You need to log in before you can comment on or make changes to this bug.