Bug 90163 - internal error: Segmentation fault
internal error: Segmentation fault
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: gcc3 (Show other bugs)
9
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-03 19:17 EDT by Need Real Name
Modified: 2007-04-18 12:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-05 19:58:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The makefile used. (21.36 KB, text/plain)
2003-06-15 05:16 EDT, Evan Clarke
no flags Details

  None (edit)
Description Need Real Name 2003-05-03 19:17:33 EDT
Description of problem:

if g++ -DHAVE_CONFIG_H -I. -I. -I../../.. -I../.. -I.. -I/usr/lib/qt-3.1/include
-I/usr/include/kde  -DQT_THREAD_SUPPORT  -D_REENTRANT  -Wnon-virtual-dtor
-Wno-long-long -Wundef -Wall -W -Wpointer-arith -Wmissing-prototypes
-Wwrite-strings -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align
-Wconversion -DNDEBUG -DNO_DEBUG -O2 -fno-exceptions -fno-check-new  -O2 -Wall
-ffast-math -fexpensive-optimizations -fomit-frame-pointer  -MT kdeapp.o -MD -MP
-MF ".deps/kdeapp.Tpo" \
  -c -o kdeapp.o `test -f 'kdeapp.cpp' || echo './'`kdeapp.cpp; \
then mv ".deps/kdeapp.Tpo" ".deps/kdeapp.Po"; \
else rm -f ".deps/kdeapp.Tpo"; exit 1; \
fi
In file included from /usr/include/kde/kfiledialog.h:32,
                 from kdeapp.cpp:56:
/usr/include/kde/kfile.h:123: internal error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[5]: *** [kdeapp.o] Error 1
make[5]: Leaving directory `/home/james/src/celestia-1.3.0/src/celestia/kde'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/home/james/src/celestia-1.3.0/src/celestia/kde'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/home/james/src/celestia-1.3.0/src/celestia'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/james/src/celestia-1.3.0/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/james/src/celestia-1.3.0'
make: *** [all] Error 2

Version-Release number of selected component (if applicable):


How reproducible:

Don't know
Steps to Reproduce:
1. down load celestia-1.3.0
2. sh ./configure (because . ./configure cashes kconsole in kde)
3. stare at the dump
    
Actual results:

/usr/include/kde/kfile.h:123: internal error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[5]: *** [kdeapp.o] Error 1
make[5]: Leaving directory `/home/james/src/celestia-1.3.0/src/celestia/kde'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/home/james/src/celestia-1.3.0/src/celestia/kde'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/home/james/src/celestia-1.3.0/src/celestia'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/james/src/celestia-1.3.0/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/james/src/celestia-1.3.0'
make: *** [all] Error 2
[james@daedalus celestia-1.3.0]$
Expected results:

finish compiling celestia-1.3.0

Additional info:

this sucks
Comment 1 Need Real Name 2003-05-08 14:35:37 EDT
This also happened while I was compiling Wine.  Twice in a row


make[2]: Leaving directory `/home/james/src/wine-20030408/dlls/glu32'
make[2]: Entering directory `/home/james/src/wine-20030408/dlls/d3d8'
gcc -c -I. -I. -I../../include -I../../include -I/usr/X11R6/include -g -O2 -Wall
-mpreferred-stack-boundary=2 -gstabs+ -Wpointer-arith  -fPIC -D__WINESRC__ 
-D_REENTRANT -o device.o device.c
device.c: In function `DrawPrimitiveI':
device.c:822: internal error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[2]: *** [device.o] Error 1
make[2]: Leaving directory `/home/james/src/wine-20030408/dlls/d3d8'
make[1]: *** [d3d8] Error 2
make[1]: Leaving directory `/home/james/src/wine-20030408/dlls'
make: *** [dlls] Error 2
Comment 2 Evan Clarke 2003-06-15 04:26:00 EDT
It is happening to me when compiling xmame 0.69.1 (m6800.c) - however when I
changed the makefile to show the compiler commandline (it defaults to a
"Compiling foobar.c..." message and recompiled to make a decent bug-report, it
did not happen.

Seems to be rather intermittent.

Sorry for the "ME TOO!" type entry.
Comment 3 Evan Clarke 2003-06-15 05:16:05 EDT
Created attachment 92405 [details]
The makefile used.

I recompiled xmame 0.69.1 again (available from x.mame.net) with fresh sources
and the attached makefile (has some things like enabling alsa), and got this
error:

Compiling src/unix/video-drivers/x11.c ...
Compiling src/unix/video-drivers/xinput.c ...
Compiling src/unix/video-drivers/xil.c ...
Compiling src/unix/video-drivers/x11_window.c ...
video-drivers/x11_window.c: In function `x11_window_update_16_to_16bpp':
video-drivers/x11_window.c:1788: internal error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[1]: *** [../../xmame.obj/unix.x11/video-drivers/x11_window.o] Error 1
make[1]: Leaving directory `/home/evan/downloads/xmame-0.69.1/src/unix'
make: *** [osdepend] Error 2

I have seen this crop up several times when recompiling mame (each time after a
make clean).  Each time is at a different source file.	Continues fine if I try
again.

gcc-3.2.2-5
glibc-2.3.2-27.9

Fairly standard RH9 setup, stock kernel 2.4.20-18.9, added alsa from
freshrpms.net.
Comment 4 GLC 2003-09-10 17:33:42 EDT
Attempting to compile 2.4.20 kernel from linux.org on RH 9 - 2.4.20-20.9 using
gcc-3.2.2.5.  Processor is i686 with 512MB memory.

Received the following during "make modules":

gcc -D__KERNEL__ -I/usr/src/linux-2.4.20/include -Wall -Wstrict-prototypes
-Wno-trigraphs -O2 -fno-strict-aliasing -fno-common -fomit-frame-pointer -pipe
-mpreferred-stack-boundary=2 -march=i686 -DMODULE -DMODVERSIONS -include
/usr/src/linux-2.4.20/include/linux/modversions.h  -nostdinc -iwithprefix
include -DKBUILD_BASENAME=parport_pc  -DEXPORT_SYMTAB -c parport_pc.c
parport_pc.c: In function `frob_set_mode':
parport_pc.c:118: internal error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[2]: *** [parport_pc.o] Error 1
make[2]: Leaving directory `/usr/src/linux-2.4.20/drivers/parport'
make[1]: *** [_modsubdir_parport] Error 2
make[1]: Leaving directory `/usr/src/linux-2.4.20/drivers'
make: *** [_mod_drivers] Error 2
Comment 5 Richard Henderson 2004-10-05 19:58:29 EDT
For the original bug report, celestia 1.3.2 builds with gcc 3.3.3 from
Fedora Core 2.

For the "me too" folk filing unrelated errors, file your own bugs.
Except for the guy with the kernel build failure; I guarantee that's
a hardware fault, since it works for everyone else.

Note You need to log in before you can comment on or make changes to this bug.