Bug 90181 - System Hangs when scsi block size set to 1024 bytes during backup
Summary: System Hangs when scsi block size set to 1024 bytes during backup
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
(Show other bugs)
Version: 2.1
Hardware: i686 Linux
high
high
Target Milestone: ---
Assignee: Tom Coughlan
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-05 00:59 UTC by se
Modified: 2007-11-30 22:06 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-22 19:45:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description se 2003-05-05 00:59:10 UTC
Description of problem:
Dell 8 way processor, 8 gigs of memory (8250).  I set the scsi block size to 
1024 bytes to increase throughput, because I have 180 gigs to backup using an 
LTO tape drive.  I am using the dell symbios controller.  After random backup 
times (usually after 1 hour of backing up) the system hangs and must be power 
cycled.  I reduced the block size to 512 bytes and the problem disappeared.

Version-Release number of selected component (if applicable):

How reproducible: so far every time

Steps to Reproduce:
1. set scsi blocksize to 1024 bytes (env variable)
2. do a backup of 150+ gigs
3. after an hour or more the system will hang -requiring a power cycle.  The 
system was not observed to be cpu bound at any time (from top).  No other 
programs were running.
    
Actual results:
Expected results:
Additional info:
Thank you!

Comment 2 Tom Coughlan 2003-08-19 19:01:36 UTC
I will investigate and see if we can fix this in the next AS 2.1 update. 

Please send the output of /var/log/messages that shows the boot-up messages.  I
would like to see 1) the kernel version, 2) which Symbois driver and version is
being used.  Also send any I/O errors that may be reported in the log during the
backup.

How exactly are you setting the scsi block size?

What are you using to do the backup?

Also, please send the output of lsmod.



Comment 3 Tom Coughlan 2004-01-22 19:45:26 UTC
No word on this for five months. Please reopen after retrying with the
latest kernel errata, and provide the requested information.


Note You need to log in before you can comment on or make changes to this bug.