Bug 90194 - aspell-es hangs evolution
Summary: aspell-es hangs evolution
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: aspell-es (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-05 09:38 UTC by Nicolas Mailhot
Modified: 2007-04-18 16:53 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-24 23:10:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nicolas Mailhot 2003-05-05 09:38:33 UTC
Description of problem:

parsing: * NAMESPACE (("" "/")) NIL NIL
namespace dump: (("" "/")) NIL NIL
Unhandled Error: The file "/usr/lib/aspell/es.rws" is not in the proper format.
Wrong Soundslike

Version-Release number of selected component (if applicable):
aspell-0.50.3-3
aspell-es-0.50-2
evolution-1.3.2-1
gnome-spell-1.0.2-1

How reproducible:
Always

Steps to Reproduce:
1. Install selected packages
2. Launch evolution
3. Go into properties
    
Actual results:
Boom

Expected results:
Property window

Comment 1 Eido Inoue 2003-05-05 15:06:02 UTC
What architecture are you running?

Comment 2 Nicolas Mailhot 2003-05-05 15:17:46 UTC
i686 & athlon

Comment 3 Eido Inoue 2003-05-05 15:22:05 UTC
Can you tell me the output of "locale"? Are you having problems/hangs with
Latin-1, UTF-8, or both?

Comment 4 Nicolas Mailhot 2003-05-05 15:28:57 UTC
[nim@ulysse nim]$ locale
LANG=fr_FR
LC_CTYPE="fr_FR"
LC_NUMERIC="fr_FR"
LC_TIME="fr_FR"
LC_COLLATE="fr_FR"
LC_MONETARY="fr_FR"
LC_MESSAGES="fr_FR"
LC_PAPER="fr_FR"
LC_NAME="fr_FR"
LC_ADDRESS="fr_FR"
LC_TELEPHONE="fr_FR"
LC_MEASUREMENT="fr_FR"
LC_IDENTIFICATION="fr_FR"
LC_ALL=

I almost never use spanish anymore, I had aspell-sp installed from long time ago
and noticed evo prefs would just hang after it was upgraded.

Just removing the packages fixes evo (not a solution for people who actually
need spanish I fear)


Comment 5 Nicolas Mailhot 2003-05-27 19:05:57 UTC
Still here with :
gnome-spell-1.0.3-3
aspell-0.50.3-8
aspell-es-0.50-2
evolution-1.3.92-1

[nim@rousalka nim]$ evolution
Unhandled Error: The file "/usr/lib/aspell/es.rws" is not in the proper format.
Wrong Soundslike


Comment 6 Nicolas Mailhot 2003-06-22 15:04:52 UTC
Just a follow-up to say aspell-en has the same effect now as of version 0.51-5 
                                                                                 
Since the message is exactly the same changed package to aspell only 
                                                                                 
en is really supposed to be the last resort, if it fails as es spelling is totally hopeless 
                                                                                 
[nim@rousalka nim]$ evolution 
                                                                                 
(evolution:13996): Bonobo-CRITICAL **: file bonobo-ui-util.c: line 182 
(bonobo_ui_util_xml_to_pixbuf): assertion `xml != NULL' failed 
                                                                                 
(evolution:13996): Bonobo-CRITICAL **: file bonobo-ui-util.c: line 182 
(bonobo_ui_util_xml_to_pixbuf): assertion `xml != NULL' failed 
Unhandled Error: The file "/usr/lib/aspell/en-only.rws" is not in the proper for mat. Wrong Soundslike 
[nim@rousalka nim]$ rpm -q aspell-en 
aspell-en-0.51-5 
 

Comment 7 Nicolas Mailhot 2003-06-24 22:21:22 UTC
Fixed by :
[root@rousalka root]# rpm -q --changelog aspell-en
* mar jun 24 2003 Adrian Havill <havill@redhat.com> 0.51-6
 
- data files are not arch independent

[root@rousalka root]# rpm -q --changelog aspell-es
* mar jun 24 2003 Adrian Havill <havill@redhat.com> 0.50-5
 
- remove buildarch; data files are platform dependent

I also noticed spanish is now available in evolution spellchecking. So the same
change in aspell-fr will probably permit closing of bug #90195.

(please close this one - I registered in bugzilla as Nicolas.Mailhot@laPoste.net
  but when I opened this bug bugzilla lowercased it as
nicolas.mailhot@laposte.net and seems to consider now those are two different users)


Comment 8 Eido Inoue 2003-06-25 03:56:54 UTC
file a bug _against_ mozilla. e-mail ids should naturally be case insensitive.

Comment 9 Nicolas Mailhot 2003-06-25 07:46:09 UTC
I opened bugzilla bug #97983 yesterday if you want to comment on it.

Comment 10 Eido Inoue 2003-06-25 15:57:19 UTC
dave will take care of it. btw, in Comment 8 I obviously meant Bugzilla, not
mozilla, but you knew that. ;)


Note You need to log in before you can comment on or make changes to this bug.