Bug 901959 - Symbolic link file - plugin.ini not updated when changing plugin
Symbolic link file - plugin.ini not updated when changing plugin
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-quantum (Show other bugs)
2.0 (Folsom)
Unspecified Unspecified
unspecified Severity unspecified
: snapshot2
: 2.1
Assigned To: Gary Kotton
Ofer Blaut
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-20 03:11 EST by Gary Kotton
Modified: 2016-04-26 16:07 EDT (History)
4 users (show)

See Also:
Fixed In Version: openstack-quantum-2012.2.1-6.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-14 13:24:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gary Kotton 2013-01-20 03:11:33 EST
Description of problem:
Updating plugins (for example OVS to linuxbridge) does not update the symbolic link file

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install OVS plugin 
2. Install linuxbridge plugin
3.
  
Actual results:
File /etc/quantum/plugin.ini has reference to OVS database 

Expected results:
File /etc/quantum/plugin.ini should have reference to LB database 

Additional info:
Comment 2 Gary Kotton 2013-01-21 05:20:24 EST
Currently updated with f18 packages
Comment 7 Ofer Blaut 2013-02-06 10:14:30 EST
It works , link is changed 

[root@intg-vdsb ~(keystone_admin)]$ ll /etc/quantum/plugin.ini
lrwxrwxrwx. 1 root root 55 Feb  4 16:17 /etc/quantum/plugin.ini -> /etc/quantum/plugins/openvswitch/ovs_quantum_plugin.ini
[root@intg-vdsb ~(keystone_admin)]$ rpm -qa | grep quantum
openstack-quantum-nicira-2012.2.1-6.el6ost.noarch
python-quantumclient-2.1.10-1.el6ost.noarch
openstack-quantum-2012.2.1-6.el6ost.noarch
openstack-quantum-cisco-2012.2.1-6.el6ost.noarch
openstack-quantum-metaplugin-2012.2.1-6.el6ost.noarch
openstack-quantum-ryu-2012.2.1-6.el6ost.noarch
openstack-quantum-openvswitch-2012.2.1-6.el6ost.noarch
python-quantum-2012.2.1-6.el6ost.noarch
openstack-quantum-nec-2012.2.1-6.el6ost.noarch
openstack-quantum-linuxbridge-2012.2.1-6.el6ost.noarch
[root@intg-vdsb ~(keystone_admin)]$ quantum-server-setup
Please select a plugin from: linuxbridge openvswitch
Choice:
linuxbridge
Quantum plugin: linuxbridge
Plugin: linuxbridge => Database: quantum_linux_bridge
Please enter the password for the 'root' MySQL user: 
Verified connectivity to MySQL.
User quantum already exists
Please enter network device for VLAN trunking:
eth3
Would you like to update the nova configuration files? (y/n): 
y
Configuration updates complete!
[root@intg-vdsb ~(keystone_admin)]$ ll /etc/quantum/plugin.ini
lrwxrwxrwx. 1 root root 53 Feb  6 19:14 /etc/quantum/plugin.ini -> /etc/quantum/plugins/linuxbridge/linuxbridge_conf.ini
Comment 9 errata-xmlrpc 2013-02-14 13:24:55 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0260.html

Note You need to log in before you can comment on or make changes to this bug.