Bug 90199 - kernel missing /proc/sys/kernel/X-workaround
kernel missing /proc/sys/kernel/X-workaround
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
: 90200 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-05 07:19 EDT by Kaj J. Niemi
Modified: 2007-04-18 12:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-07 09:10:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaj J. Niemi 2003-05-05 07:19:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030303

Description of problem:
Latest rawhide kernel seems to be missing /proc/sys/kernel/X-workaround
described in http://people.redhat.com/mingo/exec-shield/ANNOUNCE-exec-shield



Version-Release number of selected component (if applicable):
kernel-2.4.20-1.1982

How reproducible:
Always

Steps to Reproduce:
1. ls -l /proc/sys/kernel/X-workaround
2.
3.
    

Actual Results:  None found.

Expected Results:  Should be.

Additional info:
Comment 1 Arjan van de Ven 2003-05-05 07:23:20 EDT
the X in rawhide should not need this hack.....
Comment 2 Mike A. Harris 2003-05-05 14:56:44 EDT
Correct, The mprotect bits are in as of:

* Fri May  2 2003 Mike A. Harris <mharris@redhat.com> 4.3.0-8
- Enable XFree86-4.3.0-elfloader-linux-non-exec-stack.patch again, and remove
  ifnarch x86_64 on XFree86-4.3.0-xlib-dual-malloc-memleak-lcPrTxt.c.patch and
  XFree86-4.3.0-craptastic-cast.patch
- Disable XFree86-4.3.0-missing-SharedXfooReqs.patch temporarily as it breaks
  xauth + ssh on s390, and thus requires deeper investigation
- Build 4.3.0-8 for rawhide, and 4.3.0-8.RHEL.0 for RHEL devel
Comment 3 Mike A. Harris 2003-05-05 14:58:00 EDT
*** Bug 90200 has been marked as a duplicate of this bug. ***
Comment 4 Kaj J. Niemi 2003-05-06 06:03:36 EDT
Tried with

echo 0 > /proc/sys/kernel/exec-shield

in /etc/rc.local which doesn't help at all. The resulting messages are:

May  6 12:51:15 d111 init: Id "x" respawning too fast: disabled for 5 minutes
May  6 12:51:15 d111 init: Id "1" respawning too fast: disabled for 5 minutes
May  6 12:51:15 d111 init: Id "2" respawning too fast: disabled for 5 minutes
May  6 12:51:15 d111 init: Id "3" respawning too fast: disabled for 5 minutes
May  6 12:51:15 d111 init: no more processes left in this runlevel

... indicating something got hosed bigtime. If I keep exec-shield at 2 (which
was the default?) everything runs up to the point where X starts, as originally
reported.

Comment 5 Kaj J. Niemi 2003-05-06 11:34:50 EDT
Same thing with 2.4.20-1.1985
Comment 6 Arjan van de Ven 2003-05-06 11:37:30 EDT
so did you install the new, fixed X ?
Comment 7 Kaj J. Niemi 2003-05-06 12:05:29 EDT
I've had XFree86 4.3.0-8 installed since May 4th, looks like it is the latest
and greatest. I know that according to the changelog it should contain the fix. ;-)

Comment 8 Mike A. Harris 2003-05-07 03:08:45 EDT
There was an additional problem in the patch in 4.3.0-8, which is fixed in
4.3.0-10.  Please upgrade to 4.3.0-10.
Comment 9 Kaj J. Niemi 2003-05-07 04:34:04 EDT
Hi Mike,


Yup, 4.3.0-10 makes X11 work under kernel 2.4.20-1.1985.

However, there seems to be some problems with metacity/gnome. If I start my
normal session I immediately get the following error in .xsession-errors:

============================
GThread-ERROR **: file gthread-posix.c: line 135 (): error 'No such process'
during 'pthread_getschedparam (pthread_self(), &policy, &sched)'
aborting...
============================

I'm unsure where/what causes this.

Starting failsafe from gdm and then running twm from an xterm works okay.
Comment 10 Mike A. Harris 2003-05-07 09:10:26 EDT
That error doesn't have anything to do with XFree86 or the kernel.  You'll
have to file a new bug report for that if you think it is a bug.

Closing report as fixed in latest rawhide packages.  (4.3.0-10)

Note You need to log in before you can comment on or make changes to this bug.