Bug 902038 - [abrt] java-1.7.0-openjdk-1.7.0.9-2.3.4.fc18: gtk_widget_real_map: Process /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.9.x86_64/jre/bin/java was killed by signal 6 (SIGABRT)
[abrt] java-1.7.0-openjdk-1.7.0.9-2.3.4.fc18: gtk_widget_real_map: Process /u...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alexander Kurtakov
Fedora Extras Quality Assurance
abrt_hash:068574da6a19bc9446303feab24...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-20 10:12 EST by Ivan Mironov
Modified: 2014-02-05 10:23 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-05 10:23:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (160.96 KB, text/plain)
2013-01-20 10:12 EST, Ivan Mironov
no flags Details
File: build_ids (4.92 KB, text/plain)
2013-01-20 10:12 EST, Ivan Mironov
no flags Details
File: cgroup (135 bytes, text/plain)
2013-01-20 10:12 EST, Ivan Mironov
no flags Details
File: dso_list (30.53 KB, text/plain)
2013-01-20 10:12 EST, Ivan Mironov
no flags Details
File: environ (1.33 KB, text/plain)
2013-01-20 10:12 EST, Ivan Mironov
no flags Details
File: limits (1.29 KB, text/plain)
2013-01-20 10:12 EST, Ivan Mironov
no flags Details
File: maps (92.13 KB, text/plain)
2013-01-20 10:12 EST, Ivan Mironov
no flags Details
File: open_fds (11.79 KB, text/plain)
2013-01-20 10:12 EST, Ivan Mironov
no flags Details
File: proc_pid_status (915 bytes, text/plain)
2013-01-20 10:12 EST, Ivan Mironov
no flags Details
my backtrace (using Cillop-Midnite theme) (18.85 KB, text/plain)
2013-03-12 13:50 EDT, Jan Pokorný
no flags Details

  None (edit)
Description Ivan Mironov 2013-01-20 10:12:19 EST
Description of problem:
I tried to run eclipse with "non-standard" GTK+ theme: https://github.com/linvinus/Clearlooks-flat-compact

Steps to reproduce:
* Install theme
* Choose it as default GTK theme
* Try to run eclipse

Version-Release number of selected component:
java-1.7.0-openjdk-1.7.0.9-2.3.4.fc18

Additional info:
backtrace_rating: 3
cmdline:        /usr/bin/java -Xms128m -Xmx512m -Dorg.eclipse.swt.browser.UseWebKitGTK=true -Dhelp.lucene.tokenizer=standard -XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith -XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init> -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding -XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile -XX:CompileCommand=exclude,org/python/pydev/ui/filetypes/FileTypesPreferencesPage,getDottedValidSourceFiles -XX:CompileCommand=exclude,org/eclipse/tycho/core/osgitools/EquinoxResolver,newState -Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins -XX:MaxPermSize=256m -jar /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.3.0.v20121227-2039.jar -os linux -ws gtk -arch x86_64 -showsplash /usr/lib64/eclipse//plugins/org.eclipse.platform_4.2.1.v20121227-2033/splash.bmp -launcher /usr/lib64/eclipse/eclipse -name Eclipse --launcher.library /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.200.v20121227-2039/eclipse_1503.so -startup /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.3.0.v20121227-2039.jar --launcher.overrideVmargs -exitdata 9998021 -preventMasterEclipseLaunch -vm /usr/bin/java -vmargs -Xms128m -Xmx512m -Dorg.eclipse.swt.browser.UseWebKitGTK=true -Dhelp.lucene.tokenizer=standard -XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith -XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init> -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding -XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile -XX:CompileCommand=exclude,org/python/pydev/ui/filetypes/FileTypesPreferencesPage,getDottedValidSourceFiles -XX:CompileCommand=exclude,org/eclipse/tycho/core/osgitools/EquinoxResolver,newState -Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins -XX:MaxPermSize=256m -jar /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.3.0.v20121227-2039.jar
core_backtrace: 
crash_function: gtk_widget_real_map
executable:     /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.9.x86_64/jre/bin/java
kernel:         3.7.2-204.fc18.x86_64
remote_result:  NOTFOUND
uid:            1000
var_log_messages: Jan 20 20:39:45 localhost abrt[10807]: Saved core dump of pid 10722 (/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.9.x86_64/jre/bin/java) to /var/spool/abrt/ccpp-2013-01-20-20:39:29-10722 (1943126016 bytes)

Truncated backtrace:
Thread no. 1 (10 frames)
 #4 gtk_widget_real_map at gtkwidget.c:8861
 #6 _g_closure_invoke_va at gclosure.c:840
 #9 gtk_widget_map at gtkwidget.c:3437
 #10 gtk_widget_set_parent at gtkwidget.c:6466
 #11 gtk_bin_add at gtkbin.c:107
 #12 g_cclosure_marshal_VOID__OBJECTv at gmarshal.c:1312
 #13 _g_closure_invoke_va at gclosure.c:840
 #16 gtk_container_add at gtkcontainer.c:1208
 #17 gtk_tool_button_construct_contents at gtktoolbutton.c:497
 #18 _g_closure_invoke_va at gclosure.c:840
Comment 1 Ivan Mironov 2013-01-20 10:12:24 EST
Created attachment 683622 [details]
File: backtrace
Comment 2 Ivan Mironov 2013-01-20 10:12:26 EST
Created attachment 683623 [details]
File: build_ids
Comment 3 Ivan Mironov 2013-01-20 10:12:29 EST
Created attachment 683624 [details]
File: cgroup
Comment 4 Ivan Mironov 2013-01-20 10:12:31 EST
Created attachment 683625 [details]
File: dso_list
Comment 5 Ivan Mironov 2013-01-20 10:12:34 EST
Created attachment 683626 [details]
File: environ
Comment 6 Ivan Mironov 2013-01-20 10:12:36 EST
Created attachment 683627 [details]
File: limits
Comment 7 Ivan Mironov 2013-01-20 10:12:38 EST
Created attachment 683628 [details]
File: maps
Comment 8 Ivan Mironov 2013-01-20 10:12:41 EST
Created attachment 683629 [details]
File: open_fds
Comment 9 Ivan Mironov 2013-01-20 10:12:43 EST
Created attachment 683630 [details]
File: proc_pid_status
Comment 10 Deepak Bhole 2013-01-23 16:08:06 EST
SWT/JNI error. Re-assigning to Eclipse.
Comment 11 Jan Pokorný 2013-03-12 13:50:31 EDT
Created attachment 709096 [details]
my backtrace (using Cillop-Midnite theme)

Also hit this one:
Gtk:ERROR:gtkwidget.c:8861:gtk_widget_real_map: assertion failed: (gtk_widget_get_realized (widget))
Comment 12 Jan Pokorný 2013-03-12 13:53:24 EDT
Comment on attachment 709096 [details]
my backtrace (using Cillop-Midnite theme)

$ yum list installed | grep eclipse
eclipse-birt-chart.noarch       4.2.1-1.fc17        @updates                    
eclipse-dtp.noarch              1.10.1-1.fc17       @updates                    
eclipse-emf.noarch              2.8.1-1.fc17        @updates                    
eclipse-emf-core.x86_64         1:2.8.1-2.fc17      @updates                    
eclipse-equinox-osgi.x86_64     1:4.2.1-2.fc17      @updates                    
eclipse-gef.noarch              3.8.1-3.fc17        @updates                    
eclipse-jdt.x86_64              1:4.2.1-2.fc17      @updates                    
eclipse-pde.x86_64              1:4.2.1-2.fc17      @updates                    
eclipse-platform.x86_64         1:4.2.1-2.fc17      @updates                    
eclipse-rcp.x86_64              1:4.2.1-2.fc17      @updates                    
eclipse-swt.x86_64              1:4.2.1-2.fc17      @updates                    
icu4j-eclipse.noarch            1:4.4.2.2-11.fc17   @fedora
Comment 13 Jan Pokorný 2013-03-12 15:50:36 EDT
Easiest 100% reproducer for me was to "Install new software" and
answer yes upon question whether to restart Eclipse.
Comment 14 Jan Pokorný 2013-03-12 17:58:14 EDT
Well, simple close/quit is even simpler :)
Comment 15 Jan Pokorný 2013-03-12 17:59:52 EDT
... implying that I *was* able to run it as such, probably unlike
the original reporter.
Comment 16 Alexander Kurtakov 2013-04-26 03:58:30 EDT
Jan, you see the error if running with some theme or even with Adwaita?
Comment 17 Fedora End Of Life 2013-12-21 05:36:30 EST
This message is a reminder that Fedora 18 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 18. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '18'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 18's end of life.

Thank you for reporting this issue and we are sorry that we may not be 
able to fix it before Fedora 18 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior to Fedora 18's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 18 Jan Pokorný 2014-01-02 17:38:27 EST
Alexander: excuse my ignorance.

I have now tried the alleged reproducer in F19 (just to accept/refuse
closing this bug), but seems to be OK now.

eclipse-ecf-core.noarch              3.6.1-1.fc19             installed
eclipse-emf-core.noarch              1:2.9.1-1.fc19           installed
eclipse-equinox-osgi.x86_64          1:4.3.1-5.fc19           installed
eclipse-jdt.x86_64                   1:4.3.1-5.fc19           installed
eclipse-pde.x86_64                   1:4.3.1-5.fc19           installed
eclipse-platform.x86_64              1:4.3.1-5.fc19           installed
eclipse-swt.x86_64                   1:4.3.1-5.fc19           installed
icu4j-eclipse.noarch                 1:50.1.1-1.fc19          installed

So let's have this bug auto-closed.
Comment 19 Fedora End Of Life 2014-02-05 10:23:59 EST
Fedora 18 changed to end-of-life (EOL) status on 2014-01-14. Fedora 18 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.