Bug 902107 - [abrt] tigervnc-1.2.80-0.6.20121126svn5015.fc18: snprintf: Process /usr/bin/vncviewer was killed by signal 6 (SIGABRT)
[abrt] tigervnc-1.2.80-0.6.20121126svn5015.fc18: snprintf: Process /usr/bin/v...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: tigervnc (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
abrt_hash:5c835d65af2c09432d883a0e3d0...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-20 16:47 EST by Net Nut
Modified: 2013-04-30 19:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-20 18:41:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (25.88 KB, text/plain)
2013-01-20 16:47 EST, Net Nut
no flags Details
File: cgroup (127 bytes, text/plain)
2013-01-20 16:48 EST, Net Nut
no flags Details
File: core_backtrace (2.80 KB, text/plain)
2013-01-20 16:48 EST, Net Nut
no flags Details
File: dso_list (3.20 KB, text/plain)
2013-01-20 16:48 EST, Net Nut
no flags Details
File: environ (2.86 KB, text/plain)
2013-01-20 16:48 EST, Net Nut
no flags Details
File: limits (1.29 KB, text/plain)
2013-01-20 16:48 EST, Net Nut
no flags Details
File: maps (42.16 KB, text/plain)
2013-01-20 16:48 EST, Net Nut
no flags Details
File: open_fds (178 bytes, text/plain)
2013-01-20 16:48 EST, Net Nut
no flags Details
File: proc_pid_status (918 bytes, text/plain)
2013-01-20 16:48 EST, Net Nut
no flags Details
File: smolt_data (3.10 KB, text/plain)
2013-01-20 16:48 EST, Net Nut
no flags Details
File: var_log_messages (900 bytes, text/plain)
2013-01-20 16:48 EST, Net Nut
no flags Details

  None (edit)
Description Net Nut 2013-01-20 16:47:56 EST
Description of problem:
vncviewer crashes on very attempt to connect to any macine after upgrading to fc18

Version-Release number of selected component:
tigervnc-1.2.80-0.6.20121126svn5015.fc18

Additional info:
backtrace_rating: 4
cmdline:        vncviewer
crash_function: snprintf
executable:     /usr/bin/vncviewer
kernel:         3.7.2-201.fc18.x86_64
remote_result:  NOTFOUND
uid:            1500

Truncated backtrace:
Thread no. 1 (10 frames)
 #7 snprintf at /usr/include/bits/stdio2.h:65
 #8 saveViewerParameters at /usr/src/debug/tigervnc-1.2.80-20121126svn5015/vncviewer/parameters.cxx:520
 #9 ServerDialog::handleConnect at /usr/src/debug/tigervnc-1.2.80-20121126svn5015/vncviewer/ServerDialog.cxx:244
 #10 Fl_Widget::do_callback at Fl_Widget.cxx:328
 #11 do_callback at ../FL/Fl_Widget.H:857
 #12 handle at Fl_Return_Button.cxx:56
 #13 Fl_Return_Button::handle at Fl_Return_Button.cxx:52
 #14 Fl_Group::handle at Fl_Group.cxx:183
 #15 send at Fl.cxx:1104
 #16 Fl::handle_ at Fl.cxx:1362
Comment 1 Net Nut 2013-01-20 16:47:58 EST
Created attachment 683912 [details]
File: backtrace
Comment 2 Net Nut 2013-01-20 16:48:00 EST
Created attachment 683913 [details]
File: cgroup
Comment 3 Net Nut 2013-01-20 16:48:02 EST
Created attachment 683914 [details]
File: core_backtrace
Comment 4 Net Nut 2013-01-20 16:48:04 EST
Created attachment 683915 [details]
File: dso_list
Comment 5 Net Nut 2013-01-20 16:48:05 EST
Created attachment 683916 [details]
File: environ
Comment 6 Net Nut 2013-01-20 16:48:07 EST
Created attachment 683917 [details]
File: limits
Comment 7 Net Nut 2013-01-20 16:48:09 EST
Created attachment 683918 [details]
File: maps
Comment 8 Net Nut 2013-01-20 16:48:10 EST
Created attachment 683919 [details]
File: open_fds
Comment 9 Net Nut 2013-01-20 16:48:12 EST
Created attachment 683920 [details]
File: proc_pid_status
Comment 10 Net Nut 2013-01-20 16:48:13 EST
Created attachment 683921 [details]
File: smolt_data
Comment 11 Net Nut 2013-01-20 16:48:15 EST
Created attachment 683922 [details]
File: var_log_messages
Comment 12 Net Nut 2013-01-20 18:41:02 EST
the problem was related to broken .vnc preferences for the user that was not a issue in the previous OS..  removing and recreating .vnc preferences allowed vnc to function fine..
thanks

Note You need to log in before you can comment on or make changes to this bug.