Bug 902126 - /usr/bin/google-chrome: error while loading shared libraries: libudev.so.0: cannot open shared object file: No such file or directory
/usr/bin/google-chrome: error while loading shared libraries: libudev.so.0: c...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
18
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: udev-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-20 19:53 EST by xset1980
Modified: 2013-01-24 11:36 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-24 11:36:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description xset1980 2013-01-20 19:53:04 EST
Description of problem:

After the update from F17 to F18, Google Chrome, not load, and show this error:

/usr/bin/google-chrome: error while loading shared libraries: libudev.so.0: cannot open shared object file: No such file or directory

Version-Release number of selected component (if applicable):
Fedora 18 KDE i686 up to date.

How reproducible:
always

Steps to Reproduce:
1.install google chrome from Google rpm
2.type google-chrome on terminal of F18
3.
  
Actual results:


Expected results:


Additional info:

Similar bugs related on other componentes, all related with udev and systemd
============================================================================

http://superuser.com/questions/431606/why-is-google-chrome-not-starting-after-replacing-udev-with-systemd-tools

"The reason for this error is because of the transition from udev to systemd-tools. During this update /usr/lib/libudev.so.0 is renamed /usr/lib/libudev.so.1.0.1."

https://bbs.archlinux.org/viewtopic.php?id=142528

http://forums.fedoraforum.org/showthread.php?t=282076

http://comments.gmane.org/gmane.linux.arch.general/41620
Comment 1 Harald Hoyer 2013-01-24 11:36:21 EST
(In reply to comment #0)
> Description of problem:
> 
> After the update from F17 to F18, Google Chrome, not load, and show this
> error:
> 
> /usr/bin/google-chrome: error while loading shared libraries: libudev.so.0:
> cannot open shared object file: No such file or directory
> 
> Version-Release number of selected component (if applicable):
> Fedora 18 KDE i686 up to date.
> 
> How reproducible:
> always
> 
> Steps to Reproduce:
> 1.install google chrome from Google rpm
> 2.type google-chrome on terminal of F18
> 3.
>   
> Actual results:
> 
> 
> Expected results:
> 
> 
> Additional info:
> 
> Similar bugs related on other componentes, all related with udev and systemd
> ============================================================================
> 
> http://superuser.com/questions/431606/why-is-google-chrome-not-starting-
> after-replacing-udev-with-systemd-tools
> 
> "The reason for this error is because of the transition from udev to
> systemd-tools. During this update /usr/lib/libudev.so.0 is renamed
> /usr/lib/libudev.so.1.0.1."
> 
> https://bbs.archlinux.org/viewtopic.php?id=142528
> 
> http://forums.fedoraforum.org/showthread.php?t=282076
> 
> http://comments.gmane.org/gmane.linux.arch.general/41620

google should provide an F18 version of google-chrome.

Although symlinking to the old name might seem to work for you, it can horribly fail and introduce random crashes of the app using the symlink.

libudev.so.1.0.1 is _not_ equal to libudev.so.0

Note You need to log in before you can comment on or make changes to this bug.