Bug 902207 - agent-mouse=on/off can't switch mouse mode with rhel6u4 guest
agent-mouse=on/off can't switch mouse mode with rhel6u4 guest
Status: CLOSED DUPLICATE of bug 964980
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Hai Huang
Virtualization Bugs
:
Depends On:
Blocks: 964980
  Show dependency treegraph
 
Reported: 2013-01-21 02:20 EST by mazhang
Modified: 2016-09-20 00:39 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 964980 (view as bug list)
Environment:
Last Closed: 2013-08-08 14:29:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mazhang 2013-01-21 02:20:21 EST
Description of problem:
Try switch mouse mode by set "agent-mouse=on/off" in rhel7,and the
guest os was rhel6u4 but failed enable server mode, the client mouse
is not captured,still can leave client's window bounds, neither
"agent-mouse=off" nor "stop spice-vdagent service inside guest",even
removed spice-vdagent package.

Version-Release number of selected component (if applicable):
host: 
RHEL-7.0-20130108.n.0
qemu-kvm-1.3.0-3.el7.x86_64 
guest: 
RHEL6.4-20121206.0 
spice-vdagent-0.12.0-2.el6.x86_64/spice-vdagent-0.12.0-4.el6.x86_64
client:
spice-client-0.8.2-15.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Boot up guest with follow command line
##/usr/libexec/qemu-kvm -M pc -cpu SandyBridge -m 8G -smp 4,sockets=2,cores=2,threads=1,maxcpus=16 -enable-kvm -name rhel -uuid 990ea161-6b67-47b2-b803-19fb01d30d12 -smbios type=1,manufacturer='Red Hat',product='RHEV Hypervisor',version=el6,serial=koTUXQrb,uuid=feebc8fd-f8b0-4e75-abc3-e63fcdb67170 -k en-us -rtc base=localtime,clock=host,driftfix=slew -no-kvm-pit-reinjection -monitor stdio -qmp tcp:0:6666,server,nowait -boot menu=on -bios /usr/share/seabios/bios.bin -drive file=/root/images/rhel6u4.qcow2,if=none,id=drive-scsi-disk,format=qcow2,cache=none,werror=stop,rerror=stop -device virtio-scsi-pci,id=scsi0,addr=0x5 -device scsi-disk,drive=drive-scsi-disk,bus=scsi0.0,scsi-id=0,lun=0,id=scsi-disk,bootindex=1 -spice port=5900,disable-ticketing,agent-mouse=off -vga qxl -device qxl,id=redhat -device virtio-serial -chardev spicevmc,id=vdagent,name=vdagent -device virtserialport,chardev=vdagent,name=com.redhat.spice.0 -netdev tap,id=hostnet0,downscript=no -device e1000,netdev=hostnet0,id=net0,mac=00:1a:4a:2e:28:1c,bus=pci.0,addr=0x6,bootindex=2

2.click into the client window,then try move out of window

  
Actual results:
can move out of window without alt+F11.

Expected results:
release mouse by press alt+F11.

Additional info:
win7-64 did not found this issue.
Comment 2 mazhang 2013-05-27 01:55:43 EDT
In qemu monitor mouse mode keep "server", can not switch by "agent-mouse=on/off" 

(qemu) info spice 
Server:
     address: 0.0.0.0:5900
    migrated: false
        auth: none
    compiled: 0.12.2
  mouse-mode: server
Channel:
...
Comment 3 Hai Huang 2013-08-08 14:29:19 EDT

*** This bug has been marked as a duplicate of bug 964980 ***
Comment 4 mazhang 2014-06-09 07:05:08 EDT
according to comment#3, this bug has been closed.

Note You need to log in before you can comment on or make changes to this bug.