Bug 902464 - Error message when adding Server that already exists needs clarification
Error message when adding Server that already exists needs clarification
Status: CLOSED DUPLICATE of bug 894463
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Shireesh
Sudhir D
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-21 13:11 EST by Matt Mahoney
Modified: 2015-05-13 11:59 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-22 00:36:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Mahoney 2013-01-21 13:11:11 EST
Description of problem:
When adding a server that already exists, the error message "Error while executing action New Host: Internal Engine Error" needs to be more user friendly

Version-Release number of selected component (if applicable):
RHS-C QA4

How reproducible:


Steps to Reproduce:
1. Add a new server
2. Add the same server a 2nd time
3.
  
Actual results:
Error Message: "Error while executing action New Host: Internal Engine Error"

Expected results:
Error Message in RHS-C QA3 was: "Error: Cannot add host which has the same unique ID as one of the hosts: <server>.
<dustint> This might occur in case this host was already added to the system."

Additional info:
Comment 2 Shireesh 2013-01-22 00:36:57 EST

*** This bug has been marked as a duplicate of bug 894463 ***

Note You need to log in before you can comment on or make changes to this bug.