Bug 90265 - 2.5 workqueue not fully backported, breaks ALSA
Summary: 2.5 workqueue not fully backported, breaks ALSA
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 9
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-06 03:48 UTC by Alex Tribble
Modified: 2007-04-18 16:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-17 20:04:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alex Tribble 2003-05-06 03:48:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 
1.1.4322)

Description of problem:
The <workqueue.h> kernel header is the 2.5 version, but kernel/workqueue.c 
does not exist! I don't know if reverting this file breaks anything else, and 
I haven't tried it yet, but using the 2.5 version defines several macros that 
are used as indicators in ALSA of a kernel with 2.5 style workqueuing, which 
this kernel does not have. ALSA has a workaround, but it will not enable if it 
thinks the kernel has support for it. This means that when one compiles the 
alsa-driver package, module snd.o always fails to insert, because it is 
missing the symbol schedule_work.

Version-Release number of selected component (if applicable):
kernel-2.4.20-9

How reproducible:
Always

Steps to Reproduce:
1. Get redhat-9.
2. Get alsa-driver-0.9.x
3. Untar it, run configure w/whatever options - it makes no difference, and 
make.
4. make install and attempt to modprobe snd - it fails.

Actual Results:  It failed.

Expected Results:  It should have inserted.

Additional info:

Comment 1 Alex Tribble 2003-05-17 20:04:46 UTC
Never mind...


Note You need to log in before you can comment on or make changes to this bug.