Bug 90272 - Don't work with Matrox Gxxx Cards (AGP)
Don't work with Matrox Gxxx Cards (AGP)
Status: CLOSED DUPLICATE of bug 85230
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-xfree86 (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-06 07:41 EDT by Roland Kaeser
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:52:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roland Kaeser 2003-05-06 07:41:11 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Download and install the newest Matrox drivers for G400


Steps to Reproduce:
1. Download and install the newest Matrox drivers for G400
2. Try start the redhat-config-xfree86.
3. 
    
Actual results:
There are some strange Pyton errors:
/usr/share/redhat-config-xfree86/xconf.py Line: 350


Expected results:
Starting of the Config Tool

Additional info:
Comment 1 Brent Fox 2003-05-06 10:45:08 EDT
Is there more to the crash output than that one line?  That doesn't give me much
to go on.
Comment 2 Brent Fox 2003-05-06 10:59:55 EDT
Also, a copy of your /etc/X11/XF86Config file would be useful.
Comment 3 Mike A. Harris 2003-05-07 03:06:04 EDT
Also note that Red Hat does not support 3rd party drivers.  If there is
a bug in our tool, it would be nice to fix it though nonetheless.
Comment 4 Roland Kaeser 2003-05-07 04:20:01 EDT
Pyton Error 
 
* ddcprobe returned bogus values: 
ID:   None 
Name: None 
HorizSync: None 
VertSync:  None 
 
Traceback (most recent call last): 
  File "/usr/share/redhat-config-xfree86/xconf.py", line 350, in ? 
    hardware_state = XF86HardwareState(xconfig) 
  File "/usr/lib/python2.2/site-packages/rhpl/xhwstate.py", line 141, in __init__ 
    self.init_from_xconfig(xconfig) 
  File "/usr/lib/python2.2/site-packages/rhpl/xhwstate.py", line 292, in init_from_xconfig 
    self.hsync = ranges_to_string(monitor.hsync, monitor.n_hsync) 
  File "/usr/lib/python2.2/site-packages/rhpl/xhwstate.py", line 60, in ranges_to_string 
    r = array[i] 
 
Comment 5 Roland Kaeser 2003-05-07 04:22:35 EDT
XF86Config: 
 
Section "ServerLayout" 
	Identifier     "ISN Configuration." 
	Screen         "Display 1" LeftOf "Display 2" 
	Screen         "Display 2" 0 0 
	InputDevice    "Mouse0" "CorePointer" 
	InputDevice    "Keyboard0" "CoreKeyboard" 
EndSection 
 
Section "Files" 
	RgbPath      "/usr/X11R6/lib/X11/rgb" 
	FontPath     "unix/:7100" 
EndSection 
 
Section "Module" 
	Load  "dbe" 
	Load  "extmod" 
	Load  "fbdevhw" 
	Load  "glx" 
	Load  "record" 
	Load  "freetype" 
	Load  "type1" 
EndSection 
 
Section "ServerFlags" 
	Option "Xinerama" 
EndSection 
 
Section "InputDevice" 
	Identifier  "Keyboard0" 
	Driver      "keyboard" 
	Option      "XkbRules" "xfree86" 
	Option      "XkbModel" "pc105" 
	Option      "XkbLayout" "de_CH" 
EndSection 
 
Section "InputDevice" 
	Identifier  "Mouse0" 
	Driver      "mouse" 
	Option      "Protocol" "IMPS/2" 
	Option      "Device" "/dev/input/mice" 
	Option      "ZAxisMapping" "4 5" 
	Option      "Emulate3Buttons" "no" 
EndSection 
 
Section "InputDevice" 
	Identifier  "DevInputMice" 
	Driver      "mouse" 
	Option      "Protocol" "IMPS/2" 
	Option      "Device" "/dev/input/mice" 
	Option      "ZAxisMapping" "4 5" 
	Option      "Emulate3Buttons" "no" 
EndSection 
 
Section "Monitor" 
	Identifier   "Display 1" 
	VendorName   "Monitor Vendor" 
	ModelName    "Philips Brilliance 107(PRODUCT ID 17A58...)" 
	DisplaySize  300	230 
	HorizSync    30,0 - 30,0 
	HorizSync    0,0 - 95,0 
	HorizSync    0,0 - 0,0 
	VertRefresh  50,0 - 50,0 
	VertRefresh  0,0 - 160,0 
	VertRefresh  0,0 - 0,0 
	Option       "dpms" 
EndSection 
 
Section "Monitor" 
	Identifier   "Display 2" 
	VendorName   "Monitor Vendor" 
	ModelName    "Philips Brilliance 107(PRODUCT ID 17A58...)" 
	DisplaySize  300	230 
	HorizSync    30,0 - 30,0 
	HorizSync    0,0 - 95,0 
	HorizSync    0,0 - 0,0 
	VertRefresh  50,0 - 50,0 
	VertRefresh  0,0 - 160,0 
	VertRefresh  0,0 - 0,0 
EndSection 
 
Section "Device" 
	Identifier  "MATROX CARD 1" 
	Driver      "mga" 
	VendorName  "Videocard vendor" 
	BoardName   "Matrox Millennium G400" 
	VideoRam    32768 
	BusID       "PCI:1:0:0" 
EndSection 
 
Section "Device" 
	Identifier  "MATROX CARD 2" 
	Driver      "mga" 
	VendorName  "Videocard vendor" 
	BoardName   "Matrox Millennium G400" 
	VideoRam    32768 
	BusID       "PCI:1:0:0" 
	Screen      1 
EndSection 
 
Section "Screen" 
	Identifier "Display 1" 
	Device     "MATROX CARD 1" 
	Monitor    "Display 1" 
	DefaultDepth     24 
	SubSection "Display" 
		Depth     24 
		Modes    "1024x768" 
	EndSubSection 
	SubSection "Display" 
		Depth     8 
		Modes    "1024x768" 
	EndSubSection 
	SubSection "Display" 
		Depth     16 
		Modes    "1024x768" 
	EndSubSection 
EndSection 
 
Section "Screen" 
	Identifier "Display 2" 
	Device     "MATROX CARD 2" 
	Monitor    "Display 2" 
	DefaultDepth     24 
	SubSection "Display" 
		Depth     24 
		Modes    "1024x768" 
	EndSubSection 
	SubSection "Display" 
		Depth     8 
		Modes    "1024x768" 
	EndSubSection 
	SubSection "Display" 
		Depth     16 
		Modes    "1024x768" 
	EndSubSection 
EndSection 
 
Section "DRI" 
	Group        0 
	Mode         0666 
EndSection 
 
 
Comment 6 Brent Fox 2003-05-30 10:01:54 EDT
Ah, ok.  I don't think that this bug has anything to do with the Matrox drivers.
 There was a bug in pyxf86config that was causing it to convert periods to
commas in some non-us locales.

So, the section from your XF86Config file that looks like:
	HorizSync    30,0 - 30,0 
	HorizSync    0,0 - 95,0 
	HorizSync    0,0 - 0,0 
	VertRefresh  50,0 - 50,0 
	VertRefresh  0,0 - 160,0 
	VertRefresh  0,0 - 0,0 

should contain periods instead of commas.  

This bug is a duplicate of bug #85230

*** This bug has been marked as a duplicate of 85230 ***
Comment 7 Red Hat Bugzilla 2006-02-21 13:52:53 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.