Bug 902842 - eclipse: calls mvn-rpmbuild with -Dmaven.local.mode=true
eclipse: calls mvn-rpmbuild with -Dmaven.local.mode=true
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Krzysztof Daniel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-22 09:17 EST by Mikolaj Izdebski
Modified: 2014-01-12 19:27 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-28 04:05:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mikolaj Izdebski 2013-01-22 09:17:13 EST
Description of problem:
During build eclipse calls mvn-rpmbuild with argument -Dmaven.local.mode=true.

-Dmaven.local.mode is undocumented option and it's intended for internal use by maven packages only. Behavior of mvn-rpmbuild script is udefined if it's called with this option then.

Version-Release number of selected component (if applicable):
4.2.2-0.4.git20121217

Additional info:
In future versions of maven passing this option to mvn-rpmbuild may cause eclipse to FTBFS.
Comment 1 Krzysztof Daniel 2013-03-28 04:05:39 EDT
This is fixed by now.

Note You need to log in before you can comment on or make changes to this bug.