Bug 9031 - ppd dies on RedHat Linux 6.1, on a HP Pavilion Pentium III 733 MHz
ppd dies on RedHat Linux 6.1, on a HP Pavilion Pentium III 733 MHz
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: ppp (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-31 21:10 EST by Suhaib Siddiqi
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-02 14:33:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Suhaib Siddiqi 2000-01-31 21:10:11 EST
I installed RH 6.1 on a HP Pavilion P III 733 MHz PC, with Viking external
modem connected to serial port 1.  The PC contains a built-in HP Ethernet
card, which is not networked. Using rp3 or netcfg, I can dial out.  It
makes connection then sits there for ever with no IP traffic flowing, i.e
I cannot ping/ftp/telnet any host on the internet.  Looking at
the /var/log/messages, I see mdprobe error of "can't locate module char-
major-108".  Relevent part of /var/log/messages is attached bellow:

PS: using the same modem, and RH 6.1 on another older HP 200 Mhz with
plain old Pentium, but no HP network card, rp3, and netcfg can dial-out
and amke PPP connections.

Suhaib
----------------

[root@hunda log]# tail -50 messages
Jan 31 20:21:46 localhost WvDial: CONNECT 46667
Jan 31 20:21:46 localhost WvDial: Carrier detected.  Starting PPP
immediately.
Jan 31 20:21:46 localhost pppd[718]: Serial connection established.
Jan 31 20:21:46 localhost pppd[718]: Using interface ppp0
Jan 31 20:21:46 localhost pppd[718]: Connect: ppp0 <--> /dev/ttyS0
Jan 31 20:21:47 localhost kernel: PPP BSD Compression module registered
Jan 31 20:21:47 localhost kernel: PPP Deflate Compression module
registered
Jan 31 20:21:47 localhost pppd[718]: local  IP address 209.170.132.111
Jan 31 20:21:47 localhost pppd[718]: remote IP address 198.79.53.27
Jan 31 20:21:47 localhost pppd[718]: primary   DNS address 198.79.53.11
Jan 31 20:21:47 localhost pppd[718]: secondary DNS address 198.79.53.10  _-
---after this I cannot ping any host on the Internet.
Jan 31 20:22:47 localhost pppd[718]: Terminating on signal 15.
Jan 31 20:22:47 localhost pppd[718]: Connection terminated.
Jan 31 20:22:47 localhost pppd[718]: Connect time 1.1 minutes.
Jan 31 20:22:47 localhost pppd[718]: Sent 269 bytes, received 376 bytes.
Jan 31 20:22:48 localhost pppd[718]: Hangup (SIGHUP)
Jan 31 20:22:48 localhost pppd[718]: Exit.
Jan 31 20:23:05 localhost ifup-ppp: pppd started for ppp0 on /dev/ttyS0 at
115200
Jan 31 20:23:05 localhost modprobe: can't locate module char-major-108
Jan 31 20:23:05 localhost pppd[872]: pppd 2.3.10 started by root, uid 0
Jan 31 20:23:07 localhost WvDial: WvDial: Internet dialer version 1.40
Jan 31 20:23:07 localhost WvDial: Initializing modem.
Jan 31 20:23:07 localhost WvDial: Sending: ATZ
Jan 31 20:23:07 localhost WvDial: ATZ
Jan 31 20:23:07 localhost WvDial: OK
Jan 31 20:23:07 localhost WvDial: Sending: ATQ0 V1 E1 S0=0 &C1 &D2 S11=55
+FCLASS=0
Jan 31 20:23:07 localhost WvDial: ATQ0 V1 E1 S0=0 &C1 &D2 S11=55 +FCLASS=0
Jan 31 20:23:07 localhost WvDial: OK
Jan 31 20:23:07 localhost WvDial: Modem initialized.
Jan 31 20:23:07 localhost WvDial: Sending: ATDT 424-0050
Jan 31 20:23:07 localhost WvDial: Waiting for carrier.
Jan 31 20:23:07 localhost WvDial: ATDT 424-0050
Jan 31 20:23:29 localhost WvDial: CONNECT 46667
Jan 31 20:23:29 localhost WvDial: Carrier detected.  Starting PPP
immediately.
Jan 31 20:23:29 localhost pppd[872]: Serial connection established.
Jan 31 20:23:29 localhost pppd[872]: Using interface ppp0
Jan 31 20:23:29 localhost pppd[872]: Connect: ppp0 <--> /dev/ttyS0
Jan 31 20:23:30 localhost pppd[872]: local  IP address 209.170.134.49
Jan 31 20:23:30 localhost pppd[872]: remote IP address 198.79.53.9
Jan 31 20:23:30 localhost pppd[872]: primary   DNS address 198.79.53.11
Jan 31 20:23:30 localhost pppd[872]: secondary DNS address 198.79.53.10
Jan 31 20:24:40 localhost pppd[872]: Terminating on signal 15.
Jan 31 20:24:40 localhost pppd[872]: Connection terminated.
Jan 31 20:24:40 localhost pppd[872]: Connect time 1.2 minutes.
Jan 31 20:24:40 localhost pppd[872]: Sent 266 bytes, received 333 bytes.
Jan 31 20:24:41 localhost pppd[872]: Hangup (SIGHUP)
Jan 31 20:24:41 localhost pppd[872]: Exit.
Jan 31 20:25:18 localhost modprobe: can't locate module char-major-108
Jan 31 20:25:18 localhost pppd[967]: The remote system is required to
authenticate itself but I
Jan 31 20:25:18 localhost pppd[967]: couldn't find any secret (password)
which would let it use an IP address.
[root@hunda log]#
Comment 1 Nalin Dahyabhai 2000-02-01 08:42:59 EST
This is a known problem with ppp and initscripts if you also have a network card
or some other network interface up before you start ppp.    The module warning
is actually normal for the 2.2 kernel series.  The problem is actually pppd
requiring the other end of the connection to authenticate itself, and this is
causing the failure.  Try upgrading to the latest errata releases at
http://www.redhat.com/errata/, or add "noauth" to the /etc/ppp/options file.
Please reopen this bug if you continue having problems.
Comment 2 Suhaib Siddiqi 2000-02-01 09:13:59 EST
The problem I reported is with the RH 6.1 errata and also
with "noauth" /etc/ppp/options.  Therefore I assume something else is
responsible for this problem.

Suhaib
Comment 3 Nalin Dahyabhai 2000-02-01 09:24:59 EST
Whoops, missed that part.  I see that WvDial is starting up pppd immediately.
If your ISP actually requires your end of the connection to authenticate, that
would be a problem.  If you upgrade to the errata version of rp3 or grab the
latest from Raw Hide, toggling off "Let PPP do all authentication" in the
advanced tab will probably fix that.  Barring that, I'd look at your routing
table and try to see why you can't ping anything.  Does name resolution work
correctly?  Is your default route set properly?
Comment 4 Suhaib Siddiqi 2000-02-01 09:37:59 EST
I did try toggling off "Let PPP do all authentication".  NO success!!!

Also tried the latest rp3 errata from Red Hat errata.  No success!!!

Name resolution does not work either!!! the /etc/resolv.conf is OK.  Being a
system administartor  for my company network, these should be first things to
troubleshoot when a network connection fails.

My ISP PPP accept "Any Kind of authentication".  That is what I use on Windows
NT.

Same ISP and same configuration on another UP with no network card installed
works just fine.  Therefore I assume PPP is getting csrewed up seeing network
card installed.

I should have mentioned this in my previous message.  (I have all the latest
errata applied).  The only diference is that I had to build and install XFree86
3.9.17c (latest developers xfree86 snapshot) because vnidia NTN Rivia video cad
is not supported by XF86 3.3.5 and 3.3.6 gave a horrible screen display.
However, I do not believe XFree86 would have anything to do with PPP dialup
failures.

Would try latest version frm Raw Hide tonite.

Regards,

Suhaib
Comment 5 Nalin Dahyabhai 2000-02-01 09:59:59 EST
The only thing that would cause pppd to screw up with a network card is the
noauth problem, which should be fixed in the latest initscripts.  I seem to
recall that the wvdial/rp3 combination (even in the errata, another of which
will probably be released when the previous maintainer gets back from vacation)
would fail to pass "noauth" to pppd when they start pppd.

Pppd starts up, notices that a PPP link could provide the other end of the
connection with access to your network (if you have routing enabled), and
automatically requires the other end of the connection to authenticate.
Without the fixes that are as of now only in Raw Hide (or GNOME CVS, in the
case of rp3 and its included copy of wvdial), the only way to change this
behavior is to add "noauth" to /etc/ppp/options.

If upgrading to the Raw Hide versions of rp3 and wvdial doesn't fix things,
and you still see the "The remote system is required to authenticate itself"
error, then something is wrong and pppd is not being passed "noauth" on its
command-line, and I need to hunt down a case that I'm not currently aware of.
Comment 6 Suhaib Siddiqi 2000-02-02 14:33:59 EST
installing rp3 from Raw Hide fixed the PPP connection problem.  BUT,
the panel which you get when you dial (it has sliding bar while it dial-out)
never closes, and kept saying "Pleas wait making connection"...
Comment 7 Nalin Dahyabhai 2000-02-07 08:25:59 EST
I'm told that this was fixed in a recent Raw Hide version of initscripts (the
problem was that /sbin/ifup wouldn't exit, so rp3 would just get stuck waiting
for it to exit).

Note You need to log in before you can comment on or make changes to this bug.