Bug 903304 - quantum-node-setup fails to set libvirt_vif_driver with "--plugin openvswitch"
quantum-node-setup fails to set libvirt_vif_driver with "--plugin openvswitch"
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-quantum (Show other bugs)
2.0 (Folsom)
Unspecified Unspecified
unspecified Severity unspecified
: snapshot2
: 2.1
Assigned To: Gary Kotton
Ofer Blaut
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-23 11:53 EST by Alan Pevec
Modified: 2016-04-26 18:33 EDT (History)
7 users (show)

See Also:
Fixed In Version: openstack-quantum-2012.2.1-6.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 885932
Environment:
Last Closed: 2013-02-14 13:25:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alan Pevec 2013-01-23 11:53:06 EST
+++ This bug was initially created as a clone of Bug #885932 +++

Suggested patch for /usr/bin/quantum-node-setup

Description of problem:

"quantum-node-setup --plugin openvswitch" reports error as below:

-----------
# quantum-node-setup --plugin openvswitch
Quantum plugin: openvswitch
Please enter the Quantum hostname:
opst01
Would you like to update the nova configuration files? (y/n): 
y
/usr/bin/openstack-config --set|--del config_file section [parameter] [value]
Configuration updates complete!
-----------

This is because LIBVIRT_VIF_DRIVER is not set for openvswitch.

/usr/bin/quantum-node-setup
-----------
    116 case "${QUANTUM_PLUGIN}" in
    117 "linuxbridge")
    118         LIBVIRT_VIF_DRIVER=nova.virt.libvirt.vif.QuantumLinuxBridgeVIFDrive        r
    119 ;;
    120 
    121 "openvswitch")
    122         if ! rpm -q openvswitch > /dev/null
    123         then
    124                 echo "Please install openvswitch"
    125                 exit 0
    126         fi
    127 ;;
    128 
    129 esac
-----------

See the attachment for a suggested patch.

By the way, I used "LibvirtHybridOVSBridgeDriver" in this patch. There may be another choice of driver, though.

Version-Release number of selected component (if applicable):

# rpm -q openstack-quantum
openstack-quantum-2012.2.1-1.fc18.noarch

--- Additional comment from Gary Kotton on 2013-01-21 05:20:35 EST ---

Currently updated with f18 packages

f18 patch: http://pkgs.fedoraproject.org/cgit/openstack-quantum.git/commit/?h=f18&id=fb1536dff2b4e87bbc99b63bd6e8463bfe67cb38
Comment 3 Ofer Blaut 2013-02-07 07:52:15 EST
Tests  using quantum-setp

[DEFAULT]
core_plugin = quantum.plugins.openvswitch.ovs_quantum_plugin.OVSQuantumPluginV2


openstack-quantum-2012.2.1-6.el6ost.noarch

OVS + traffic
Comment 5 errata-xmlrpc 2013-02-14 13:25:13 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0260.html

Note You need to log in before you can comment on or make changes to this bug.